CVE-2024-24773 Apache Superset: Improper validation of SQL statements allows for unauthorized access to data

Medium 4.9 Published Updated

Authenticated users can bypass data authorization scopes in Apache Superset SQLLab to access unauthorized data.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-24773?

CVE-2024-24773 is a medium-severity missing authorization vulnerability in Apache Superset, published on 28 Feb 2024. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Improper parsing of nested SQL statements on SQLLab would allow authenticated users to surpass their data authorization scope. This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1.

Users are recommended to upgrade to version 3.1.1, which fixes the issue.

Weakness: CWE-863

Which versions are affected by CVE-2024-24773?

6 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.

PackageAffectedFixed in
apache-superset PyPIAll versions3.0.4, 3.1.1
apache-superset PyPIAll versions3.0.4
apache-superset PyPIAll versions3.0.4
apache-superset PyPIFrom 3.1.03.1.1
apache-superset PyPIFrom 3.1.03.1.1
superset BitnamiAll versions4.1.1

Products include Apache Superset.

How do I fix CVE-2024-24773?

Upgrade apache-superset to a fixed version for your release line: 3.0.4 or 3.1.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2024-24773 being exploited?

There is no known exploitation of CVE-2024-24773 in the wild and no public exploit code.

All Apache Superset vulnerabilities

Sources

Also known as BIT-superset-2024-24773, GHSA-5474-f7g5-273q, PYSEC-2026-1160.

Is CVE-2024-24773 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free