CVE-2024-24778 Apache StreamPipes: Resources Permission Escalation

Medium 6.5 Published Updated

Registered users can access unauthorized resources via a REST interface if the resource ID is known, requiring an upgrade to fix.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-24778?

CVE-2024-24778 is a medium-severity missing authorization vulnerability in Apache StreamPipes, published on 3 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Improper privilege management in a REST interface allowed registered users to access unauthorized resources if the resource ID was know.

This issue affects Apache StreamPipes: through 0.95.1.

Users are recommended to upgrade to version 0.97.0 which fixes the issue.

Weakness: CWE-269

Which versions are affected by CVE-2024-24778?

5 open source packages ship an affected version, including org.apache.streampipes:streampipes-parent and streampipes. It affects 1 product.

PackageAffectedFixed in
org.apache.streampipes:streampipes-parent MavenAll versions0.97.0
org.apache.streampipes:streampipes-parent MavenAll versions0.97.0
streampipes PyPIAll versions0.97.0
streampipes PyPIAll versions0.97.0
streampipes PyPIAll versions0.97.0

Products include Apache Streampipes.

How do I fix CVE-2024-24778?

Upgrade org.apache.streampipes:streampipes-parent to 0.97.0 or later.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2024-24778 being exploited?

There is no known exploitation of CVE-2024-24778 in the wild and no public exploit code.

Sources

Also known as GHSA-vm7w-2724-5m23, PYSEC-2025-66.

Is CVE-2024-24778 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free