# CVE-2024-24778: Apache StreamPipes: Resources Permission Escalation

> Registered users can access unauthorized resources via a REST interface if the resource ID is known, requiring an upgrade to fix.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Mar 2025
- **Updated:** 3 Mar 2025
- **Also known as:** GHSA-vm7w-2724-5m23, PYSEC-2025-66

## What is CVE-2024-24778?

CVE-2024-24778 is a medium-severity missing authorization vulnerability in Apache StreamPipes, published on 3 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Improper privilege management in a REST interface allowed registered users to access unauthorized resources if the resource ID was know. 

This issue affects Apache StreamPipes: through 0.95.1.

Users are recommended to upgrade to version 0.97.0 which fixes the issue.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2024-24778?

5 open source packages ship an affected version, including org.apache.streampipes:streampipes-parent and streampipes. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.streampipes:streampipes-parent` | Maven | All versions | 0.97.0 |
| `org.apache.streampipes:streampipes-parent` | Maven | All versions | 0.97.0 |
| `streampipes` | PyPI | All versions | 0.97.0 |
| `streampipes` | PyPI | All versions | 0.97.0 |
| `streampipes` | PyPI | All versions | 0.97.0 |

Products: Apache Streampipes.

## How do I fix CVE-2024-24778?

Upgrade org.apache.streampipes:streampipes-parent to 0.97.0 or later.

## Is CVE-2024-24778 being exploited?

There is no known exploitation of CVE-2024-24778 in the wild and no public exploit code.

## Other vulnerabilities in Apache StreamPipes

- [CVE-2024-29868](https://insights.sbomify.com/CVE-2024-29868/): Apache StreamPipes: Use of Cryptographically Weak Pseudo-Random Number Generator (PRNG) in Recovery Token Generation (critical 9.1)
- [CVE-2023-31469](https://insights.sbomify.com/CVE-2023-31469/): Apache StreamPipes: Privilege escalation through non-admin user (high 8.8)
- [CVE-2025-47411](https://insights.sbomify.com/CVE-2025-47411/): Apache StreamPipes: Leverage of User ID for Privilege Escalation (high 8.1)
- [CVE-2024-31979](https://insights.sbomify.com/CVE-2024-31979/): Apache StreamPipes: Possibility of SSRF in pipeline element installation process (high 7.5)
- [CVE-2024-31411](https://insights.sbomify.com/CVE-2024-31411/): Apache StreamPipes: Potential remote code execution (RCE) via file upload (medium 6.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-24778 and fix it if it is affected.

What it is: CVE-2024-24778 is a medium-severity missing authorization vulnerability in Apache StreamPipes, published on 3 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-24778 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.streampipes:streampipes-parent (Maven): affected all versions; fixed in 0.97.0
- org.apache.streampipes:streampipes-parent (Maven): affected all versions; fixed in 0.97.0
- streampipes (PyPI): affected all versions; fixed in 0.97.0
- streampipes (PyPI): affected all versions; fixed in 0.97.0
- streampipes (PyPI): affected all versions; fixed in 0.97.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-24778/ (Markdown: https://insights.sbomify.com/CVE-2024-24778/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-24778
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-24778
- OSV: https://osv.dev/vulnerability/CVE-2024-24778

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-24778/
Summaries are generated and may contain mistakes; the official description above is the record.
