# CVE-2024-24779: Apache Superset: Improper data authorization when creating a new dataset

> Users with specific write permissions can create virtual datasets to access unauthorized data in Apache Superset.

- **Severity:** Medium 5.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Feb 2024
- **Updated:** 13 Feb 2025
- **Also known as:** BIT-superset-2024-24779, GHSA-wr6g-9wcr-cmqj, PYSEC-2026-1191

## What is CVE-2024-24779?

CVE-2024-24779 is a medium-severity missing authorization vulnerability in Apache Superset, published on 28 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Apache Superset with custom roles that include `can write on dataset` and without all data access permissions, allows for users to create virtual datasets to data they don't have access to. These users could then use those virtual datasets to get access to unauthorized data.
This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1.

Users are recommended to upgrade to version 3.1.1 or 3.0.4, which fixes the issue.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2024-24779?

6 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-superset` | PyPI | All versions | 3.0.4, 3.1.1 |
| `apache-superset` | PyPI | All versions | 3.0.4 |
| `apache-superset` | PyPI | All versions | 3.0.4 |
| `apache-superset` | PyPI | From 3.1.0 | 3.1.1 |
| `apache-superset` | PyPI | From 3.1.0 | 3.1.1 |
| `superset` | Bitnami | All versions | 4.1.1 |

Products: Apache Superset.

## How do I fix CVE-2024-24779?

Upgrade apache-superset to a fixed version for your release line: 3.0.4 or 3.1.1.

## Is CVE-2024-24779 being exploited?

There is no known exploitation of CVE-2024-24779 in the wild and no public exploit code.

## Other vulnerabilities in Apache Superset

- [CVE-2023-27524](https://insights.sbomify.com/CVE-2023-27524/): Apache Superset Insecure Default Initialization of Resource (high 8.9, exploited in the wild)
- [CVE-2022-27479](https://insights.sbomify.com/CVE-2022-27479/): SQL injection vulnerability in chart data API (critical 9.8)
- [CVE-2018-8021](https://insights.sbomify.com/CVE-2018-8021/): Deserialization of Untrusted Data in superset (critical 9.8)
- [CVE-2023-49657](https://insights.sbomify.com/CVE-2023-49657/): Apache Superset: Stored XSS in Dashboard Title and Chart Title (critical 9.6)
- [CVE-2022-43719](https://insights.sbomify.com/CVE-2022-43719/): Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-24779 and fix it if it is affected.

What it is: CVE-2024-24779 is a medium-severity missing authorization vulnerability in Apache Superset, published on 28 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-24779 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-superset (PyPI): affected all versions; fixed in 3.0.4, 3.1.1
- apache-superset (PyPI): affected all versions; fixed in 3.0.4
- apache-superset (PyPI): affected all versions; fixed in 3.0.4
- apache-superset (PyPI): affected from 3.1.0; fixed in 3.1.1
- apache-superset (PyPI): affected from 3.1.0; fixed in 3.1.1
- superset (Bitnami): affected all versions; fixed in 4.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-24779/ (Markdown: https://insights.sbomify.com/CVE-2024-24779/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-24779
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-24779
- OSV: https://osv.dev/vulnerability/CVE-2024-24779

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-24779/
Summaries are generated and may contain mistakes; the official description above is the record.
