CVE-2024-24795 Apache HTTP Server: HTTP Response Splitting in multiple modules

Medium 6.3 Published Updated

Attackers can inject headers to cause HTTP desynchronization in Apache HTTP Server, requiring an upgrade to mitigate.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-24795?

CVE-2024-24795 is a medium-severity vulnerability in Apache Http Server, published on 4 Apr 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

HTTP Response splitting in multiple modules in Apache HTTP Server allows an attacker that can inject malicious response headers into backend applications to cause an HTTP desynchronization attack.

Users are recommended to upgrade to version 2.4.59, which fixes this issue.

Weakness: CWE-444, CWE-113

Which versions are affected by CVE-2024-24795?

1 open source package ship an affected version, including apache. It affects 7 products.

PackageAffectedFixed in
apache BitnamiFrom 2.4.02.4.59
Linux distribution packages (7)
uwsgi SUSE:Linux Enterprise Module for Package Hub 15 SP5All versions2.0.19.1-150300.3.3.1
uwsgi SUSE:Linux Enterprise Module for Package Hub 15 SP5All versions2.0.19.1-150400.8.3.1
uwsgi SUSE:Linux Enterprise Module for Package Hub 15 SP6All versions2.0.19.1-150300.3.3.1
uwsgi SUSE:Linux Enterprise Module for Package Hub 15 SP6All versions2.0.19.1-150400.8.3.1
uwsgi openSUSE:Leap 15.5All versions2.0.19.1-150400.8.3.1
uwsgi openSUSE:Leap 15.6All versions2.0.19.1-150400.8.3.1
uwsgi openSUSE:TumbleweedAll versions2.0.28-1.1

Products include Apache Http Server, Apple Macos, Broadcom Fabric Operating System, Debian Debian Linux, Fedoraproject Fedora, Netapp Ontap and 1 more.

How do I fix CVE-2024-24795?

Upgrade apache to 2.4.59 or later.

Is CVE-2024-24795 being exploited?

There is no known exploitation of CVE-2024-24795 in the wild and no public exploit code.

All Apache Http Server vulnerabilities

Sources

Also known as ALPINE-CVE-2024-24795, AZL-39997, AZL-40040, BELL-CVE-2024-24795, BIT-apache-2024-24795, CLEANSTART-2026-PP94302 and 6 more.

Is CVE-2024-24795 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free