# CVE-2024-24795: Apache HTTP Server: HTTP Response Splitting in multiple modules

> Attackers can inject headers to cause HTTP desynchronization in Apache HTTP Server, requiring an upgrade to mitigate.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Apr 2024
- **Updated:** 12 Nov 2024
- **Also known as:** ALPINE-CVE-2024-24795, AZL-39997, AZL-40040, BELL-CVE-2024-24795, BIT-apache-2024-24795, CLEANSTART-2026-PP94302, DEBIAN-CVE-2024-24795, GHSA-c4ch-cv96-r58v, SUSE-SU-2024:3853-1, SUSE-SU-2024:3861-1, UBUNTU-CVE-2024-24795, openSUSE-SU-2024:14463-1

## What is CVE-2024-24795?

CVE-2024-24795 is a medium-severity vulnerability in Apache Http Server, published on 4 Apr 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

HTTP Response splitting in multiple modules in Apache HTTP Server allows an attacker that can inject malicious response headers into backend applications to cause an HTTP desynchronization attack.

Users are recommended to upgrade to version 2.4.59, which fixes this issue.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests), CWE-113 (Improper Neutralization of CRLF Sequences in HTTP Headers)

## Which versions are affected by CVE-2024-24795?

1 open source package ship an affected version, including apache. It affects 7 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache` | Bitnami | From 2.4.0 | 2.4.59 |
| `uwsgi` | SUSE:Linux Enterprise Module for Package Hub 15 SP5 | All versions | 2.0.19.1-150300.3.3.1 |
| `uwsgi` | SUSE:Linux Enterprise Module for Package Hub 15 SP5 | All versions | 2.0.19.1-150400.8.3.1 |
| `uwsgi` | SUSE:Linux Enterprise Module for Package Hub 15 SP6 | All versions | 2.0.19.1-150300.3.3.1 |
| `uwsgi` | SUSE:Linux Enterprise Module for Package Hub 15 SP6 | All versions | 2.0.19.1-150400.8.3.1 |
| `uwsgi` | openSUSE:Leap 15.5 | All versions | 2.0.19.1-150400.8.3.1 |
| `uwsgi` | openSUSE:Leap 15.6 | All versions | 2.0.19.1-150400.8.3.1 |
| `uwsgi` | openSUSE:Tumbleweed | All versions | 2.0.28-1.1 |

Products: Apache Http Server, Apple Macos, Broadcom Fabric Operating System, Debian Debian Linux, Fedoraproject Fedora, Netapp Ontap, Netapp Ontap Tools.

## How do I fix CVE-2024-24795?

Upgrade apache to 2.4.59 or later.

## Is CVE-2024-24795 being exploited?

There is no known exploitation of CVE-2024-24795 in the wild and no public exploit code.

## Other vulnerabilities in Apache Http Server

- [CVE-2021-42013](https://insights.sbomify.com/CVE-2021-42013/): Apache HTTP Server Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2024-38475](https://insights.sbomify.com/CVE-2024-38475/): Apache HTTP Server Improper Escaping of Output (critical 9.1, exploited in the wild)
- [CVE-2021-40438](https://insights.sbomify.com/CVE-2021-40438/): Apache HTTP Server-Side Request Forgery (SSRF) (critical 9.0, exploited in the wild)
- [CVE-2019-0211](https://insights.sbomify.com/CVE-2019-0211/): Apache HTTP Server Privilege Escalation (high 7.8, exploited in the wild)
- [CVE-2021-41773](https://insights.sbomify.com/CVE-2021-41773/): Apache HTTP Server Path Traversal (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-24795 and fix it if it is affected.

What it is: CVE-2024-24795 is a medium-severity vulnerability in Apache Http Server, published on 4 Apr 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-24795 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache (Bitnami): affected from 2.4.0; fixed in 2.4.59

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-24795/ (Markdown: https://insights.sbomify.com/CVE-2024-24795/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-24795
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-24795
- OSV: https://osv.dev/vulnerability/CVE-2024-24795

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-24795/
Summaries are generated and may contain mistakes; the official description above is the record.
