# CVE-2024-24811: Products.SQLAlchemyDA vulnerable to unauthenticated arbitrary SQL query execution


- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 7 Feb 2024
- **Updated:** 15 May 2025
- **Also known as:** GHSA-r3jc-3qmm-w3pw, PYSEC-2026-489

## What is CVE-2024-24811?

CVE-2024-24811 is a critical vulnerability in zopefoundation Products.SQLAlchemyDA, published on 7 Feb 2024. 

### Official description

SQLAlchemyDA is a generic database adapter for ZSQL methods. A vulnerability found in versions prior to 2.2 allows unauthenticated execution of arbitrary SQL statements on the database to which the SQLAlchemyDA instance is connected. All users are affected. The problem has been patched in version 2.2. There is no workaround for the problem.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2024-24811?

3 open source packages ship an affected version, including Products.SQLAlchemyDA and products-sqlalchemyda. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Products.SQLAlchemyDA` | PyPI | All versions | 2.2 |
| `products-sqlalchemyda` | PyPI | All versions | 2.2 |
| `products-sqlalchemyda` | PyPI | All versions | 2.2 |

Products: Zope Sqlalchemyda.

## How do I fix CVE-2024-24811?

Upgrade Products.SQLAlchemyDA to 2.2 or later.

## Is CVE-2024-24811 being exploited?

There is no known exploitation of CVE-2024-24811 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-24811 and fix it if it is affected.

What it is: CVE-2024-24811 is a critical vulnerability in zopefoundation Products.SQLAlchemyDA, published on 7 Feb 2024. 
Exploitation: There is no known exploitation of CVE-2024-24811 in the wild and no public exploit code.

Affected packages and fixed versions:
- Products.SQLAlchemyDA (PyPI): affected all versions; fixed in 2.2
- products-sqlalchemyda (PyPI): affected all versions; fixed in 2.2
- products-sqlalchemyda (PyPI): affected all versions; fixed in 2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-24811/ (Markdown: https://insights.sbomify.com/CVE-2024-24811/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-24811
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-24811
- OSV: https://osv.dev/vulnerability/CVE-2024-24811

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-24811/
Summaries are generated and may contain mistakes; the official description above is the record.
