# CVE-2024-24813: Frappe SQL Injection from reporting logic

> Attackers can exploit SQL injection in Frappe's reporting logic to access unauthorized data, requiring a patch to secure the application.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 20 Mar 2024
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-fxfv-7gwx-54jh

## What is CVE-2024-24813?

CVE-2024-24813 is a high-severity SQL injection vulnerability in frappe, published on 20 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Frappe is a full-stack web application framework. Prior to versions 14.64.0 and 15.0.0, SQL injection from a particular whitelisted method can result in access to data which the user doesn't have permission to access. Versions 14.64.0 and 15.0.0 contain a patch for this issue. No known workarounds are available.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2024-24813?

It affects 1 product.


Products: Frappe Frappe.

## How do I fix CVE-2024-24813?

No fix has been published for CVE-2024-24813 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-24813 being exploited?

There is no known exploitation of CVE-2024-24813 in the wild and no public exploit code.

## Other vulnerabilities in frappe

- [CVE-2019-14965](https://insights.sbomify.com/CVE-2019-14965/): Code injection in n/a (critical 9.8)
- [CVE-2026-35614](https://insights.sbomify.com/CVE-2026-35614/): Frappe has a SQL injection in bulk_update (critical 9.3)
- [CVE-2026-31877](https://insights.sbomify.com/CVE-2026-31877/): Frappe SQL Injection due to improper field sanitization (critical 9.3)
- [CVE-2025-68929](https://insights.sbomify.com/CVE-2025-68929/): Frappe may be vulnerable remote code execution due to server-side template injection (critical 9.1)
- [CVE-2019-14966](https://insights.sbomify.com/CVE-2019-14966/): SQL injection in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-24813 and fix it if it is affected.

What it is: CVE-2024-24813 is a high-severity SQL injection vulnerability in frappe, published on 20 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-24813 in the wild and no public exploit code.

Affected product: frappe. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-24813/ (Markdown: https://insights.sbomify.com/CVE-2024-24813/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-24813
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-24813
- OSV: https://osv.dev/vulnerability/CVE-2024-24813

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-24813/
Summaries are generated and may contain mistakes; the official description above is the record.
