CVE-2024-24815 CKEditor4 Cross-site scripting (XSS) vulnerability caused by incorrect CDATA detection
Attackers can inject malicious JavaScript via malformed HTML in CKEditor4 when full-page editing or specific CDATA filtering is enabled.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2024-24815?
CVE-2024-24815 is a medium-severity cross-site scripting vulnerability in ckeditor4, published on 7 Feb 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
CKEditor4 is an open source what-you-see-is-what-you-get HTML editor. A cross-site scripting vulnerability has been discovered in the core HTML parsing module in versions of CKEditor4 prior to 4.24.0-lts. It may affect all editor instances that enabled full-page editing mode or enabled CDATA elements in Advanced Content Filtering configuration (defaults to `script` and `style` elements). The vulnerability allows attackers to inject malformed HTML content bypassing Advanced Content Filtering mechanism, which could result in executing JavaScript code. An attacker could abuse faulty CDATA content detection and use it to prepare an intentional attack on the editor. A fix is available in version 4.24.0-lts.
Weakness: CWE-79
Which versions are affected by CVE-2024-24815?
4 open source packages ship an affected version, including ckeditor4 and ckeditor/ckeditor. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
ckeditor4 npm | All versions | 4.24.0-lts |
ckeditor4 npm | All versions | 4.24.0-lts |
ckeditor/ckeditor Packagist | All versions | 4.24.0 |
ckeditor/ckeditor Packagist | All versions | 4.24.0 |
Linux distribution packages (3)
python-django-ckeditor SUSE:Package Hub 15 SP5 | All versions | 6.7.2-bp155.3.3.1 |
python-django-ckeditor openSUSE:Leap 15.5 | All versions | 6.7.2-bp155.3.3.1 |
python-django-ckeditor openSUSE:Tumbleweed | All versions | 6.7.2-1.1 |
Products include Ckeditor Ckeditor.
How do I fix CVE-2024-24815?
Upgrade ckeditor4 to 4.24.0-lts or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2024-24815 being exploited?
There is no known exploitation of CVE-2024-24815 in the wild and no public exploit code.
Other vulnerabilities in ckeditor4
- CVE-2023-31541 File upload in n/a
- CVE-2021-41164 Advanced Content Filter (ACF) vulnerability allowing to execute JavaScript code using malformed HTML
- CVE-2021-41165 HTML comments vulnerability allowing to execute JavaScript code
- CVE-2021-32808 Cross-site scripting in ckeditor via abuse of undo functionality
- CVE-2011-4972 Missing authorization in CKEditor Drupal module
Sources
Also known as DEBIAN-CVE-2024-24815, GHSA-fq6h-4g8v-qqvm, UBUNTU-CVE-2024-24815, openSUSE-SU-2024:14557-1, openSUSE-SU-2025:0008-1.