{"answers":{"affected":"2 open source packages ship an affected version, including ckeditor4. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-24816 in the wild and no public exploit code.","fix":"Upgrade ckeditor4 to 4.24.0-lts or later.","what":"CVE-2024-24816 is a medium-severity cross-site scripting vulnerability in ckeditor4, published on 7 Feb 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-24816 and fix it if it is affected.\n\nWhat it is: CVE-2024-24816 is a medium-severity cross-site scripting vulnerability in ckeditor4, published on 7 Feb 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-24816 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ckeditor4 (npm): affected all versions; fixed in 4.24.0-lts\n- ckeditor4 (npm): affected all versions; fixed in 4.24.0-lts\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-24816/ (Markdown: https://insights.sbomify.com/CVE-2024-24816/index.md)","id":"CVE-2024-24816","markdown":"https://insights.sbomify.com/CVE-2024-24816/index.md","name":"CVE-2024-24816","record":{"aliases":["DEBIAN-CVE-2024-24816","GHSA-mw2c-vx6j-mg76","UBUNTU-CVE-2024-24816"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"CKEditor 4","requires_auth":"none","summary":"An attacker can execute JavaScript via XSS in CKEditor 4 samples using the preview feature, affecting integrators who deploy these samples in production.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"ckeditor","vendor":"ckeditor"}],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"CKEditor4 is an open source what-you-see-is-what-you-get HTML editor. A cross-site scripting vulnerability vulnerability has been discovered in versions prior to 4.24.0-lts in samples that use the `preview` feature. All integrators that use these samples in the production code can be affected. The vulnerability allows an attacker to execute JavaScript code by abusing the misconfigured preview feature. It affects all users using the CKEditor 4 at version \u003c 4.24.0-lts with affected samples used in a production environment. A fix is available in version 4.24.0-lts.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":"2024-02-10","github_poc":1,"max_poc_stars":2,"metasploit":0,"nuclei":0,"refs":[{"date":"2024-02-10T10:26:35Z","kind":"github_poc","ref":"https://github.com/afine-com/CVE-2024-24816","stars":2,"title":"CKEditor 4 \u003c 4.24.0-lts - XSS vulnerability in samples that use the \"preview\" feature."}],"tier":"poc_unverified"},"has_fix":true,"headline":"Cross-site scripting (XSS) vulnerability in samples with enabled the preview feature","id":"CVE-2024-24816","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":3,"next":{"headline":"User can see invitees in events created in PMs and private categories","id":"CVE-2024-24817"},"packages":[{"ecosystem":"npm","fixed":["4.24.0-lts"],"introduced":["0"],"last_affected":[],"package":"ckeditor4","purl":null,"source":"GHSA-mw2c-vx6j-mg76"},{"ecosystem":"npm","fixed":["4.24.0-lts"],"introduced":["0"],"last_affected":[],"package":"ckeditor4","purl":"pkg:npm/ckeditor4","source":"GHSA-mw2c-vx6j-mg76"}],"prev":{"headline":"CKEditor4 Cross-site scripting (XSS) vulnerability caused by incorrect CDATA detection","id":"CVE-2024-24815"},"products":["ckeditor4"],"published":"2024-02-07","related":[{"cvss_score":9.8,"headline":"File upload in n/a","id":"CVE-2023-31541","kev_date_added":null,"published":"2023-06-13"},{"cvss_score":8.2,"headline":"Advanced Content Filter (ACF) vulnerability allowing to execute JavaScript code using malformed HTML","id":"CVE-2021-41164","kev_date_added":null,"published":"2021-11-17"},{"cvss_score":8.2,"headline":"HTML comments vulnerability allowing to execute JavaScript code","id":"CVE-2021-41165","kev_date_added":null,"published":"2021-11-17"},{"cvss_score":7.6,"headline":"Cross-site scripting in ckeditor via abuse of undo functionality","id":"CVE-2021-32808","kev_date_added":null,"published":"2021-08-12"},{"cvss_score":7.5,"headline":"Missing authorization in CKEditor Drupal module","id":"CVE-2011-4972","kev_date_added":null,"published":"2019-11-13"},{"cvss_score":7.3,"headline":"Execution of JavaScript code using malformed HTML in ckeditor","id":"CVE-2021-37695","kev_date_added":null,"published":"2021-08-12"},{"cvss_score":6.8,"headline":"Code injection in n/a","id":"CVE-2012-2067","kev_date_added":null,"published":"2012-09-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-01","vendors":["ckeditor"]},"summary":"An attacker can execute JavaScript via XSS in CKEditor 4 samples using the preview feature, affecting integrators who deploy these samples in production.","url":"https://insights.sbomify.com/CVE-2024-24816/"}