# CVE-2024-24816: Cross-site scripting (XSS) vulnerability in samples with enabled the preview feature

> An attacker can execute JavaScript via XSS in CKEditor 4 samples using the preview feature, affecting integrators who deploy these samples in production.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Feb 2024
- **Updated:** 1 Aug 2024
- **Also known as:** DEBIAN-CVE-2024-24816, GHSA-mw2c-vx6j-mg76, UBUNTU-CVE-2024-24816

## What is CVE-2024-24816?

CVE-2024-24816 is a medium-severity cross-site scripting vulnerability in ckeditor4, published on 7 Feb 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

CKEditor4 is an open source what-you-see-is-what-you-get HTML editor. A cross-site scripting vulnerability vulnerability has been discovered in versions prior to 4.24.0-lts in samples that use the `preview` feature. All integrators that use these samples in the production code can be affected. The vulnerability allows an attacker to execute JavaScript code by abusing the misconfigured preview feature. It affects all users using the CKEditor 4 at version < 4.24.0-lts with affected samples used in a production environment. A fix is available in version 4.24.0-lts.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-24816?

2 open source packages ship an affected version, including ckeditor4. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ckeditor4` | npm | All versions | 4.24.0-lts |
| `ckeditor4` | npm | All versions | 4.24.0-lts |

Products: Ckeditor Ckeditor.

## How do I fix CVE-2024-24816?

Upgrade ckeditor4 to 4.24.0-lts or later.

## Is CVE-2024-24816 being exploited?

There is no known exploitation of CVE-2024-24816 in the wild and no public exploit code.

Public exploit code:

- CKEditor 4 < 4.24.0-lts - XSS vulnerability in samples that use the "preview" feature. (github_poc): https://github.com/afine-com/CVE-2024-24816

## Other vulnerabilities in ckeditor4

- [CVE-2023-31541](https://insights.sbomify.com/CVE-2023-31541/): File upload in n/a (critical 9.8)
- [CVE-2021-41164](https://insights.sbomify.com/CVE-2021-41164/): Advanced Content Filter (ACF) vulnerability allowing to execute JavaScript code using malformed HTML (high 8.2)
- [CVE-2021-41165](https://insights.sbomify.com/CVE-2021-41165/): HTML comments vulnerability allowing to execute JavaScript code (high 8.2)
- [CVE-2021-32808](https://insights.sbomify.com/CVE-2021-32808/): Cross-site scripting in ckeditor via abuse of undo functionality (high 7.6)
- [CVE-2011-4972](https://insights.sbomify.com/CVE-2011-4972/): Missing authorization in CKEditor Drupal module (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-24816 and fix it if it is affected.

What it is: CVE-2024-24816 is a medium-severity cross-site scripting vulnerability in ckeditor4, published on 7 Feb 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-24816 in the wild and no public exploit code.

Affected packages and fixed versions:
- ckeditor4 (npm): affected all versions; fixed in 4.24.0-lts
- ckeditor4 (npm): affected all versions; fixed in 4.24.0-lts

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-24816/ (Markdown: https://insights.sbomify.com/CVE-2024-24816/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-24816
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-24816
- OSV: https://osv.dev/vulnerability/CVE-2024-24816

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-24816/
Summaries are generated and may contain mistakes; the official description above is the record.
