# CVE-2024-24818: EspoCRM weakness in "Forgot password"

> Attackers can inject arbitrary domains in the password change page to redirect victims to malicious sites, potentially stealing credentials.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:A/AC:H/PR:N/UI:R/S:U/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Feb 2024
- **Updated:** 5 Aug 2024
- **Also known as:** BIT-espocrm-2024-24818, GHSA-8gv6-8r33-fm7j

## What is CVE-2024-24818?

CVE-2024-24818 is a medium-severity vulnerability in espocrm, published on 29 Feb 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

EspoCRM is an Open Source Customer Relationship Management software. An attacker can inject arbitrary IP or domain in "Password Change" page and redirect victim to malicious page that could lead to  credential stealing or another attack. This vulnerability is fixed in 8.1.2.

Weakness: CWE-601 (URL Redirection to Untrusted Site), CWE-610 (Externally Controlled Reference to a Resource in Another Sphere)

## Which versions are affected by CVE-2024-24818?

1 open source package ship an affected version, including espocrm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `espocrm` | Bitnami | All versions | 8.1.2 |

Products: Espocrm Espocrm.

## How do I fix CVE-2024-24818?

Upgrade espocrm to 8.1.2 or later.

## Is CVE-2024-24818 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-24818 exists.

## Other vulnerabilities in espocrm

- [CVE-2014-7985](https://insights.sbomify.com/CVE-2014-7985/): Path traversal in n/a (critical 10.0)
- [CVE-2026-33656](https://insights.sbomify.com/CVE-2026-33656/): Path traversal in espocrm (critical 9.1)
- [CVE-2022-38843](https://insights.sbomify.com/CVE-2022-38843/): File upload in n/a (high 8.8)
- [CVE-2019-14351](https://insights.sbomify.com/CVE-2019-14351/): Information disclosure in n/a (high 8.8)
- [CVE-2020-37094](https://insights.sbomify.com/CVE-2020-37094/): EspoCRM 5.7.0 < 5.9.0 - Two-Factor Authentication Bypass via Auth Token Reuse Between Accounts with Identical Passwords (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-24818 and fix it if it is affected.

What it is: CVE-2024-24818 is a medium-severity vulnerability in espocrm, published on 29 Feb 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-24818 exists.

Affected packages and fixed versions:
- espocrm (Bitnami): affected all versions; fixed in 8.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-24818/ (Markdown: https://insights.sbomify.com/CVE-2024-24818/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-24818
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-24818
- OSV: https://osv.dev/vulnerability/CVE-2024-24818

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-24818/
Summaries are generated and may contain mistakes; the official description above is the record.
