{"answers":{"affected":"2 open source packages ship an affected version, including pimcore/admin-ui-classic-bundle. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-24822 in the wild and no public exploit code.","fix":"Upgrade pimcore/admin-ui-classic-bundle to 1.3.3 or later.","what":"CVE-2024-24822 is a medium-severity missing authorization vulnerability in pimcore admin-ui-classic-bundle, published on 7 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-24822 and fix it if it is affected.\n\nWhat it is: CVE-2024-24822 is a medium-severity missing authorization vulnerability in pimcore admin-ui-classic-bundle, published on 7 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-24822 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pimcore/admin-ui-classic-bundle (Packagist): affected all versions; fixed in 1.3.3\n- pimcore/admin-ui-classic-bundle (Packagist): affected all versions; fixed in 1.3.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-24822/ (Markdown: https://insights.sbomify.com/CVE-2024-24822/index.md)","id":"CVE-2024-24822","markdown":"https://insights.sbomify.com/CVE-2024-24822/index.md","name":"CVE-2024-24822","record":{"aliases":["GHSA-3rfr-mpfj-2jwq"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Pimcore admin bundle","requires_auth":"low_privilege","summary":"Attackers can create or delete tags in Pimcore Admin Classic Bundle without proper permissions, allowing unauthorized data modification.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"admin_classic_bundle","vendor":"pimcore"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"}],"description":"Pimcore's Admin Classic Bundle provides a backend user interface for Pimcore. Prior to version 1.3.3, an attacker can create, delete etc. tags without having the permission to do so. A fix is available in version 1.3.3. As a workaround, one may apply the patch manually.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Pimcore Admin Classic Bundle permissions are not getting checked when working with tags","id":"CVE-2024-24822","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"missing_authorization","year":"2024"},"n_packages":2,"n_references":3,"next":{"headline":"graylog2-server Session Fixation vulnerability through cookie injection","id":"CVE-2024-24823"},"packages":[{"ecosystem":"Packagist","fixed":["1.3.3"],"introduced":["0"],"last_affected":[],"package":"pimcore/admin-ui-classic-bundle","purl":null,"source":"GHSA-3rfr-mpfj-2jwq"},{"ecosystem":"Packagist","fixed":["1.3.3"],"introduced":["0"],"last_affected":[],"package":"pimcore/admin-ui-classic-bundle","purl":"pkg:composer/pimcore/admin-ui-classic-bundle","source":"GHSA-3rfr-mpfj-2jwq"}],"prev":{"headline":"Code execution and possible privilege escalation via compromised InstalledVersions.php or installed.php in Composer","id":"CVE-2024-24821"},"products":["admin-ui-classic-bundle"],"published":"2024-02-07","related":[{"cvss_score":8.8,"headline":"Pimcore Admin Classic Bundle SQL Injection in Admin download files as zip","id":"CVE-2024-23646","kev_date_added":null,"published":"2024-01-24"},{"cvss_score":8.8,"headline":"Pimcore Admin Classic Bundle host header injection in the password reset","id":"CVE-2024-23648","kev_date_added":null,"published":"2024-01-24"},{"cvss_score":8.5,"headline":"Pimcore Admin UI has Two Factor Authentication disabled for non admin security firewalls","id":"CVE-2023-49075","kev_date_added":null,"published":"2023-11-28"},{"cvss_score":8.1,"headline":"Pimcore Host Header Injection in user invitation link","id":"CVE-2024-25625","kev_date_added":null,"published":"2024-02-19"},{"cvss_score":6.9,"headline":"Pimcore Admin Classic Bundle allows user enumeration","id":"CVE-2025-24980","kev_date_added":null,"published":"2025-02-07"},{"cvss_score":6.3,"headline":"Pimcore vulnerable to disclosure of system and database information behind /admin firewall","id":"CVE-2024-41109","kev_date_added":null,"published":"2024-07-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-11-07","vendors":["pimcore"]},"summary":"Attackers can create or delete tags in Pimcore Admin Classic Bundle without proper permissions, allowing unauthorized data modification.","url":"https://insights.sbomify.com/CVE-2024-24822/"}