# CVE-2024-24822: Pimcore Admin Classic Bundle permissions are not getting checked when working with tags

> Attackers can create or delete tags in Pimcore Admin Classic Bundle without proper permissions, allowing unauthorized data modification.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Feb 2024
- **Updated:** 7 Nov 2024
- **Also known as:** GHSA-3rfr-mpfj-2jwq

## What is CVE-2024-24822?

CVE-2024-24822 is a medium-severity missing authorization vulnerability in pimcore admin-ui-classic-bundle, published on 7 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Pimcore's Admin Classic Bundle provides a backend user interface for Pimcore. Prior to version 1.3.3, an attacker can create, delete etc. tags without having the permission to do so. A fix is available in version 1.3.3. As a workaround, one may apply the patch manually.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2024-24822?

2 open source packages ship an affected version, including pimcore/admin-ui-classic-bundle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pimcore/admin-ui-classic-bundle` | Packagist | All versions | 1.3.3 |
| `pimcore/admin-ui-classic-bundle` | Packagist | All versions | 1.3.3 |

Products: Pimcore Admin Classic Bundle.

## How do I fix CVE-2024-24822?

Upgrade pimcore/admin-ui-classic-bundle to 1.3.3 or later.

## Is CVE-2024-24822 being exploited?

There is no known exploitation of CVE-2024-24822 in the wild and no public exploit code.

## Other vulnerabilities in pimcore admin-ui-classic-bundle

- [CVE-2024-23646](https://insights.sbomify.com/CVE-2024-23646/): Pimcore Admin Classic Bundle SQL Injection in Admin download files as zip (high 8.8)
- [CVE-2024-23648](https://insights.sbomify.com/CVE-2024-23648/): Pimcore Admin Classic Bundle host header injection in the password reset (high 8.8)
- [CVE-2023-49075](https://insights.sbomify.com/CVE-2023-49075/): Pimcore Admin UI has Two Factor Authentication disabled for non admin security firewalls (high 8.5)
- [CVE-2024-25625](https://insights.sbomify.com/CVE-2024-25625/): Pimcore Host Header Injection in user invitation link (high 8.1)
- [CVE-2025-24980](https://insights.sbomify.com/CVE-2025-24980/): Pimcore Admin Classic Bundle allows user enumeration (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-24822 and fix it if it is affected.

What it is: CVE-2024-24822 is a medium-severity missing authorization vulnerability in pimcore admin-ui-classic-bundle, published on 7 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-24822 in the wild and no public exploit code.

Affected packages and fixed versions:
- pimcore/admin-ui-classic-bundle (Packagist): affected all versions; fixed in 1.3.3
- pimcore/admin-ui-classic-bundle (Packagist): affected all versions; fixed in 1.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-24822/ (Markdown: https://insights.sbomify.com/CVE-2024-24822/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-24822
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-24822
- OSV: https://osv.dev/vulnerability/CVE-2024-24822

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-24822/
Summaries are generated and may contain mistakes; the official description above is the record.
