{"answers":{"affected":"4 open source packages ship an affected version, including org.graylog2:graylog2-server. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-24823 in the wild and no public exploit code.","fix":"Upgrade org.graylog2:graylog2-server to a fixed version for your release line: 5.1.11 or 5.2.4.","what":"CVE-2024-24823 is a medium-severity authentication bypass vulnerability in graylog2-server, published on 7 Feb 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-24823 and fix it if it is affected.\n\nWhat it is: CVE-2024-24823 is a medium-severity authentication bypass vulnerability in graylog2-server, published on 7 Feb 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-24823 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.graylog2:graylog2-server (Maven): affected from 4.3.0; fixed in 5.1.11\n- org.graylog2:graylog2-server (Maven): affected from 4.3.0; fixed in 5.1.11\n- org.graylog2:graylog2-server (Maven): affected from 5.2.0-alpha.1; fixed in 5.2.4\n- org.graylog2:graylog2-server (Maven): affected from 5.2.0-alpha.1; fixed in 5.2.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-24823/ (Markdown: https://insights.sbomify.com/CVE-2024-24823/index.md)","id":"CVE-2024-24823","markdown":"https://insights.sbomify.com/CVE-2024-24823/index.md","name":"CVE-2024-24823","record":{"aliases":["GHSA-3xf8-g8gr-g7rh"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["privilege_escalation","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Graylog log management","requires_auth":"high_privilege","summary":"Attackers can hijack Graylog sessions by injecting cookies during reauthentication, potentially gaining elevated access to user accounts.","user_interaction":"required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"graylog","vendor":"graylog"}],"cvss":{"score":5.7,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-384","name":"Session Fixation"}],"description":"Graylog is a free and open log management platform. Starting in version 4.3.0 and prior to versions 5.1.11 and 5.2.4, reauthenticating with an existing session cookie would re-use that session id, even if for different user credentials. In this case, the pre-existing session could be used to gain elevated access to an existing Graylog login session, provided the malicious user could successfully inject their session cookie into someone else's browser. The complexity of such an attack is high, because it requires presenting a spoofed login screen and injection of a session cookie into an existing browser, potentially through a cross-site scripting attack. No such attack has been discovered. Graylog 5.1.11 and 5.2.4, and any versions of the 6.0 development branch, contain patches to not re-use sessions under any circumstances. Some workarounds are available. Using short session expiration and explicit log outs of unused sessions can help limiting the attack vector. Unpatched this vulnerability exists, but is relatively hard to exploit. A proxy could be leveraged to clear the `authentication` cookie for the Graylog server URL for the `/api/system/sessions` endpoint, as that is the only one vulnerable.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"graylog2-server Session Fixation vulnerability through cookie injection","id":"CVE-2024-24823","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"auth_bypass","year":"2024"},"n_packages":4,"n_references":3,"next":{"headline":"graylog2-server vulnerable to instantiation of arbitrary classes triggered by API request","id":"CVE-2024-24824"},"packages":[{"ecosystem":"Maven","fixed":["5.1.11"],"introduced":["4.3.0"],"last_affected":[],"package":"org.graylog2:graylog2-server","purl":null,"source":"GHSA-3xf8-g8gr-g7rh"},{"ecosystem":"Maven","fixed":["5.1.11"],"introduced":["4.3.0"],"last_affected":[],"package":"org.graylog2:graylog2-server","purl":"pkg:maven/org.graylog2/graylog2-server","source":"GHSA-3xf8-g8gr-g7rh"},{"ecosystem":"Maven","fixed":["5.2.4"],"introduced":["5.2.0-alpha.1"],"last_affected":[],"package":"org.graylog2:graylog2-server","purl":null,"source":"GHSA-3xf8-g8gr-g7rh"},{"ecosystem":"Maven","fixed":["5.2.4"],"introduced":["5.2.0-alpha.1"],"last_affected":[],"package":"org.graylog2:graylog2-server","purl":"pkg:maven/org.graylog2/graylog2-server","source":"GHSA-3xf8-g8gr-g7rh"}],"prev":{"headline":"Pimcore Admin Classic Bundle permissions are not getting checked when working with tags","id":"CVE-2024-24822"},"products":["graylog2-server"],"published":"2024-02-07","related":[{"cvss_score":9.8,"headline":"Information disclosure in n/a","id":"CVE-2021-37759","kev_date_added":null,"published":"2021-07-31"},{"cvss_score":9.8,"headline":"Information disclosure in n/a","id":"CVE-2021-37760","kev_date_added":null,"published":"2021-07-31"},{"cvss_score":9.3,"headline":"Incorrect management of session invalidation vulnerability in Graylog Web Interface","id":"CVE-2026-1435","kev_date_added":null,"published":"2026-02-18"},{"cvss_score":8.8,"headline":"Graylog vulnerable to privilege escalation through API tokens","id":"CVE-2025-53106","kev_date_added":null,"published":"2025-07-02"},{"cvss_score":8.8,"headline":"graylog2-server vulnerable to instantiation of arbitrary classes triggered by API request","id":"CVE-2024-24824","kev_date_added":null,"published":"2024-02-07"},{"cvss_score":8.1,"headline":"Improper Certificate Validation in Graylog","id":"CVE-2020-15813","kev_date_added":null,"published":"2020-07-17"},{"cvss_score":8,"headline":"Graylog Allows Session Takeover via Insufficient HTML Sanitization","id":"CVE-2025-46827","kev_date_added":null,"published":"2025-05-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-01","vendors":["Graylog2"]},"summary":"Attackers can hijack Graylog sessions by injecting cookies during reauthentication, potentially gaining elevated access to user accounts.","url":"https://insights.sbomify.com/CVE-2024-24823/"}