# CVE-2024-24824: graylog2-server vulnerable to instantiation of arbitrary classes triggered by API request

> Authenticated attackers can execute arbitrary code or read files by triggering class instantiation via the cluster config API endpoint.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Feb 2024
- **Updated:** 17 Jun 2025
- **Also known as:** GHSA-p6gg-5hf4-4rgj

## What is CVE-2024-24824?

CVE-2024-24824 is a high-severity code injection vulnerability in graylog2-server, published on 7 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Graylog is a free and open log management platform. Starting in version 2.0.0 and prior to versions 5.1.11 and 5.2.4, arbitrary classes can be loaded and instantiated using a HTTP PUT request to the `/api/system/cluster_config/` endpoint. Graylog's cluster config system uses fully qualified class names as config keys. To validate the existence of the requested class before using them, Graylog loads the class using the class loader. If a user with the appropriate permissions performs the request, arbitrary classes with 1-arg String constructors can be instantiated. This will execute arbitrary code that is run during class instantiation. In the specific use case of `java.io.File`, the behavior of the internal web-server stack will lead to information exposure by including the entire file content in the response to the REST request. Versions 5.1.11 and 5.2.4 contain a fix for this issue.

Weakness: CWE-863 (Incorrect Authorization), CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2024-24824?

4 open source packages ship an affected version, including org.graylog2:graylog2-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.graylog2:graylog2-server` | Maven | From 2.0.0 | 5.1.11 |
| `org.graylog2:graylog2-server` | Maven | From 2.0.0 | 5.1.11 |
| `org.graylog2:graylog2-server` | Maven | From 5.2.0-alpha.1 | 5.2.4 |
| `org.graylog2:graylog2-server` | Maven | From 5.2.0-alpha.1 | 5.2.4 |

Products: Graylog Graylog.

## How do I fix CVE-2024-24824?

Upgrade org.graylog2:graylog2-server to a fixed version for your release line: 5.1.11 or 5.2.4.

## Is CVE-2024-24824 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-24824 exists.

Public exploit code:

- Proof-of-concept exploit for CVE-2024-24824 demonstrating how an arbitrary class loading primitive can be transformed into remote code execution on vulnerable Graylog deployments. (github_poc): https://github.com/rootkiTED/graylog-cve-2024-24824-exploit

## Other vulnerabilities in graylog2-server

- [CVE-2021-37759](https://insights.sbomify.com/CVE-2021-37759/): Information disclosure in n/a (critical 9.8)
- [CVE-2021-37760](https://insights.sbomify.com/CVE-2021-37760/): Information disclosure in n/a (critical 9.8)
- [CVE-2026-1435](https://insights.sbomify.com/CVE-2026-1435/): Incorrect management of session invalidation vulnerability in Graylog Web Interface (critical 9.3)
- [CVE-2025-53106](https://insights.sbomify.com/CVE-2025-53106/): Graylog vulnerable to privilege escalation through API tokens (high 8.8)
- [CVE-2020-15813](https://insights.sbomify.com/CVE-2020-15813/): Improper Certificate Validation in Graylog (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-24824 and fix it if it is affected.

What it is: CVE-2024-24824 is a high-severity code injection vulnerability in graylog2-server, published on 7 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-24824 exists.

Affected packages and fixed versions:
- org.graylog2:graylog2-server (Maven): affected from 2.0.0; fixed in 5.1.11
- org.graylog2:graylog2-server (Maven): affected from 2.0.0; fixed in 5.1.11
- org.graylog2:graylog2-server (Maven): affected from 5.2.0-alpha.1; fixed in 5.2.4
- org.graylog2:graylog2-server (Maven): affected from 5.2.0-alpha.1; fixed in 5.2.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-24824/ (Markdown: https://insights.sbomify.com/CVE-2024-24824/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-24824
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-24824
- OSV: https://osv.dev/vulnerability/CVE-2024-24824

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-24824/
Summaries are generated and may contain mistakes; the official description above is the record.
