# CVE-2024-24825: TokenManager not checking permissions on cached tokens in DIRAC

> Attackers can access tokens requested by other users, exposing resources to unintended parties in the DIRAC distributed resource framework.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Feb 2024
- **Updated:** 17 Jun 2025
- **Also known as:** GHSA-59qj-jcjv-662j, PYSEC-2024-125

## What is CVE-2024-24825?

CVE-2024-24825 is a critical missing authorization vulnerability in DIRACGrid DIRAC, published on 8 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

DIRAC is a distributed resource framework. In affected versions any user could get a token that has been requested by another user/agent. This may expose resources to unintended parties. This issue has been addressed in release version 8.0.37. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2024-24825?

5 open source packages ship an affected version, including dirac and DIRAC. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dirac` | PyPI | All versions | 8.0.37 |
| `dirac` | PyPI | All versions | 8.0.37 |
| `dirac` | PyPI | All versions | 8.0.37 |
| `dirac` | PyPI | From 8.0.0 | 8.0.37 |
| `DIRAC` | PyPI | From 8.0.0 | 8.0.37 |

Products: Diracgrid Dirac.

## How do I fix CVE-2024-24825?

Upgrade dirac to 8.0.37 or later.

## Is CVE-2024-24825 being exploited?

There is no known exploitation of CVE-2024-24825 in the wild and no public exploit code.

## Other vulnerabilities in DIRACGrid DIRAC

- [CVE-2024-29905](https://insights.sbomify.com/CVE-2024-29905/): DIRAC: Unauthorized users can read proxy contents during generation (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-24825 and fix it if it is affected.

What it is: CVE-2024-24825 is a critical missing authorization vulnerability in DIRACGrid DIRAC, published on 8 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-24825 in the wild and no public exploit code.

Affected packages and fixed versions:
- dirac (PyPI): affected all versions; fixed in 8.0.37
- dirac (PyPI): affected all versions; fixed in 8.0.37
- dirac (PyPI): affected all versions; fixed in 8.0.37
- dirac (PyPI): affected from 8.0.0; fixed in 8.0.37
- DIRAC (PyPI): affected from 8.0.0; fixed in 8.0.37

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-24825/ (Markdown: https://insights.sbomify.com/CVE-2024-24825/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-24825
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-24825
- OSV: https://osv.dev/vulnerability/CVE-2024-24825

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-24825/
Summaries are generated and may contain mistakes; the official description above is the record.
