# CVE-2024-24829: SSRF in Sentry via Phabricator integration

> An attacker with Sentry access can trigger SSRF via Phabricator integration to scan internal networks and interact with internal services.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 8 Feb 2024
- **Updated:** 1 Aug 2024
- **Also known as:** GHSA-rqxh-fp9p-p98r

## What is CVE-2024-24829?

CVE-2024-24829 is a medium-severity server-side request forgery vulnerability in getsentry sentry, published on 8 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Sentry is an error tracking and performance monitoring platform. Sentry’s integration platform provides a way for external services to interact with Sentry. One of such integrations, the Phabricator integration (maintained by Sentry) with version <=24.1.1 contains a constrained SSRF vulnerability. An attacker could make Sentry send POST HTTP requests to arbitrary URLs (including internal IP addresses) by providing an unsanitized input to the Phabricator integration. However, the body payload is constrained to a specific format. If an attacker has access to a Sentry instance, this allows them to: 1. interact with internal network; 2. scan local/remote ports. This issue has been fixed in Sentry self-hosted release 24.1.2, and has already been mitigated on sentry.io on February 8. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2024-24829?

It affects 1 product.


Products: Sentry Sentry.

## How do I fix CVE-2024-24829?

No fix has been published for CVE-2024-24829 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-24829 being exploited?

There is no known exploitation of CVE-2024-24829 in the wild and no public exploit code.

## Other vulnerabilities in getsentry sentry

- [CVE-2026-42354](https://insights.sbomify.com/CVE-2026-42354/): Sentry: Improper authentication on SAML SSO process allows user identity linking (critical 9.1)
- [CVE-2026-27197](https://insights.sbomify.com/CVE-2026-27197/): Sentry: Improper Authentication on SAML SSO process allows user identity linking (critical 9.1)
- [CVE-2021-47935](https://insights.sbomify.com/CVE-2021-47935/): Sentry 8.2.0 Remote Code Execution via Pickle Deserialization (high 8.7)
- [CVE-2023-39349](https://insights.sbomify.com/CVE-2023-39349/): Sentry vulnerable to privilege escalation via ApiTokensEndpoint (high 8.1)
- [CVE-2023-36826](https://insights.sbomify.com/CVE-2023-36826/): Sentry vulnerable to improper authorization on debug and artifact file downloads (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-24829 and fix it if it is affected.

What it is: CVE-2024-24829 is a medium-severity server-side request forgery vulnerability in getsentry sentry, published on 8 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-24829 in the wild and no public exploit code.

Affected product: getsentry sentry. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-24829/ (Markdown: https://insights.sbomify.com/CVE-2024-24829/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-24829
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-24829
- OSV: https://osv.dev/vulnerability/CVE-2024-24829

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-24829/
Summaries are generated and may contain mistakes; the official description above is the record.
