# CVE-2024-24989: NGINX HTTP/3 QUIC vulnerability

> Attackers can cause NGINX worker process termination via HTTP/3 QUIC requests, requiring the experimental module to be enabled.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Feb 2024
- **Updated:** 12 May 2025
- **Also known as:** BIT-nginx-2024-24989, BIT-nginx-gateway-2024-24989, DEBIAN-CVE-2024-24989, GHSA-m46h-9pv9-w5xp, openSUSE-SU-2024:13701-1

## What is CVE-2024-24989?

CVE-2024-24989 is a high-severity vulnerability in F5 NGINX Open Source, published on 14 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

When NGINX Plus or NGINX OSS are configured to use the HTTP/3 QUIC module, undisclosed requests can cause NGINX worker processes to terminate.

Note: The HTTP/3 QUIC module is not enabled by default and is considered experimental. For more information, refer to  Support for QUIC and HTTP/3 https://nginx.org/en/docs/quic.html .

NOTE: Software versions which have reached End of Technical Support (EoTS) are not evaluated

Weakness: CWE-476 (NULL Pointer Dereference)

## Which versions are affected by CVE-2024-24989?

2 open source packages ship an affected version, including nginx and nginx-gateway. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nginx` | Bitnami | From 1.25.3 | 1.25.4 |
| `nginx-gateway` | Bitnami | From 1.25.3 | 1.25.4 |
| `nginx` | openSUSE:Tumbleweed | All versions | 1.25.4-1.1 |

Products: F5 Nginx Open Source, F5 Nginx Plus.

## How do I fix CVE-2024-24989?

Upgrade nginx to 1.25.4 or later.

## Is CVE-2024-24989 being exploited?

There is no known exploitation of CVE-2024-24989 in the wild and no public exploit code.

## Other vulnerabilities in F5 NGINX Open Source

- [CVE-2026-27654](https://insights.sbomify.com/CVE-2026-27654/): NGINX ngx_http_dav_module vulnerability (high 8.8)
- [CVE-2026-27651](https://insights.sbomify.com/CVE-2026-27651/): NGINX ngx_mail_auth_http_module vulnerability (high 8.7)
- [CVE-2026-27784](https://insights.sbomify.com/CVE-2026-27784/): NGINX ngx_http_mp4_module vulnerability (high 8.5)
- [CVE-2026-32647](https://insights.sbomify.com/CVE-2026-32647/): NGINX ngx_http_mp4_module vulnerability (high 8.5)
- [CVE-2024-24990](https://insights.sbomify.com/CVE-2024-24990/): NGINX HTTP/3 QUIC vulnerability (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-24989 and fix it if it is affected.

What it is: CVE-2024-24989 is a high-severity vulnerability in F5 NGINX Open Source, published on 14 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-24989 in the wild and no public exploit code.

Affected packages and fixed versions:
- nginx (Bitnami): affected from 1.25.3; fixed in 1.25.4
- nginx-gateway (Bitnami): affected from 1.25.3; fixed in 1.25.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-24989/ (Markdown: https://insights.sbomify.com/CVE-2024-24989/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-24989
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-24989
- OSV: https://osv.dev/vulnerability/CVE-2024-24989

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-24989/
Summaries are generated and may contain mistakes; the official description above is the record.
