{"answers":{"affected":"2 open source packages ship an affected version, including nginx and nginx-gateway. It affects 2 products.","exploited":"There is no known exploitation of CVE-2024-24990 in the wild and no public exploit code.","fix":"Upgrade nginx to 1.25.4 or later.","what":"CVE-2024-24990 is a high-severity use after free vulnerability in F5 NGINX Open Source, published on 14 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-24990 and fix it if it is affected.\n\nWhat it is: CVE-2024-24990 is a high-severity use after free vulnerability in F5 NGINX Open Source, published on 14 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-24990 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nginx (Bitnami): affected from 1.25.0; fixed in 1.25.4\n- nginx-gateway (Bitnami): affected from 1.25.0; fixed in 1.25.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-24990/ (Markdown: https://insights.sbomify.com/CVE-2024-24990/index.md)","id":"CVE-2024-24990","markdown":"https://insights.sbomify.com/CVE-2024-24990/index.md","name":"CVE-2024-24990","record":{"aliases":["BIT-nginx-2024-24990","BIT-nginx-gateway-2024-24990","DEBIAN-CVE-2024-24990","GHSA-38gr-cjjp-3f5w"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"NGINX web server","requires_auth":"none","summary":"Attackers can crash NGINX worker processes via HTTP/3 QUIC requests, requiring the experimental module to be enabled.","user_interaction":"not_required","vuln_class":"use_after_free"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"f5","cpe":[{"product":"nginx_open_source","vendor":"f5"},{"product":"nginx_plus","vendor":"f5"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-416","name":"Use After Free"}],"description":"When NGINX Plus or NGINX OSS are configured to use the HTTP/3 QUIC module, undisclosed requests can cause NGINX worker processes to terminate.\n\nNote: The HTTP/3 QUIC module is not enabled by default and is considered experimental. For more information, refer to  Support for QUIC and HTTP/3 https://nginx.org/en/docs/quic.html .\n\n \n\nNote: Software versions which have reached End of Technical Support (EoTS) are not evaluated","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"NGINX HTTP/3 QUIC vulnerability","id":"CVE-2024-24990","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"use_after_free","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"Null dereference in Avalanche","id":"CVE-2024-24991"},"packages":[{"ecosystem":"Bitnami","fixed":["1.25.4"],"introduced":["1.25.0"],"last_affected":[],"package":"nginx","purl":"pkg:bitnami/nginx","source":"BIT-nginx-2024-24990"},{"ecosystem":"Bitnami","fixed":["1.25.4"],"introduced":["1.25.0"],"last_affected":[],"package":"nginx-gateway","purl":"pkg:bitnami/nginx-gateway","source":"BIT-nginx-gateway-2024-24990"}],"prev":{"headline":"NGINX HTTP/3 QUIC vulnerability","id":"CVE-2024-24989"},"products":["NGINX Open Source","NGINX Plus"],"published":"2024-02-14","related":[{"cvss_score":8.8,"headline":"NGINX ngx_http_dav_module vulnerability","id":"CVE-2026-27654","kev_date_added":null,"published":"2026-03-24"},{"cvss_score":8.7,"headline":"NGINX ngx_mail_auth_http_module vulnerability","id":"CVE-2026-27651","kev_date_added":null,"published":"2026-03-24"},{"cvss_score":8.5,"headline":"NGINX ngx_http_mp4_module vulnerability","id":"CVE-2026-27784","kev_date_added":null,"published":"2026-03-24"},{"cvss_score":8.5,"headline":"NGINX ngx_http_mp4_module vulnerability","id":"CVE-2026-32647","kev_date_added":null,"published":"2026-03-24"},{"cvss_score":7.5,"headline":"NGINX HTTP/3 QUIC vulnerability","id":"CVE-2024-24989","kev_date_added":null,"published":"2024-02-14"},{"cvss_score":6.5,"headline":"NGINX HTTP/3 QUIC vulnerability","id":"CVE-2024-32760","kev_date_added":null,"published":"2024-05-29"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-08","vendors":["F5"]},"summary":"Attackers can crash NGINX worker processes via HTTP/3 QUIC requests, requiring the experimental module to be enabled.","url":"https://insights.sbomify.com/CVE-2024-24990/"}