CVE-2024-25065 Apache OFBiz: Path traversal allowing authentication bypass.
Attackers can bypass authentication via path traversal in Apache OFBiz, requiring an upgrade to the latest version.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2024-25065?
CVE-2024-25065 is a critical path traversal vulnerability in Apache Ofbiz, published on 28 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Possible path traversal in Apache OFBiz allowing authentication bypass. Users are recommended to upgrade to version 18.12.12, that fixes the issue.
Weakness: CWE-22
Which versions are affected by CVE-2024-25065?
It affects 1 product.
Products include Apache Ofbiz.
How do I fix CVE-2024-25065?
No fix has been published for CVE-2024-25065 yet. Limit exposure of the affected software until one is available.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2024-25065 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-25065 exists.
Other vulnerabilities in Apache Ofbiz
- CVE-2024-45195 Apache OFBiz Forced Browsing
- CVE-2024-32113 Apache OFBiz Path Traversal
- CVE-2024-38856 Apache OFBiz Incorrect Authorization
- CVE-2013-2250 Code injection in n/a
- CVE-2012-3506 Unspecified vulnerability in the Apache Open For Business Project (aka OFBiz) 10.04.x before 10.04.03 has unknown impact and attack vectors.
Sources
Also known as GHSA-3vg3-g88w-vjgf.