# CVE-2024-25090: Cross-site scripting in Apache Roller

> Authenticated users can inject scripts via profile or bookmark fields in untrusted-user mode, potentially leading to session hijacking or malicious actions.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 26 Jul 2024
- **Updated:** 14 Mar 2025
- **Also known as:** GHSA-g9rf-qc6j-h2f7

## What is CVE-2024-25090?

CVE-2024-25090 is a medium-severity cross-site scripting vulnerability in Apache Roller, published on 26 Jul 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Insufficient input validation and sanitation in Profile name & screenname, Bookmark name & description and blogroll name features in all versions of Apache Roller on all platforms allows an authenticated user to perform an XSS attack. Mitigation: if you do not have Roller configured for untrusted users, then you need to do nothing because you trust your users to author raw HTML and other web content. If you are running with untrusted users then you should upgrade to Roller 6.1.3.

This issue affects Apache Roller: from 5.0.0 before 6.1.3.

Users are recommended to upgrade to version 6.1.3, which fixes the issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2024-25090?

It affects 1 product.


Products: Apache Roller.

## How do I fix CVE-2024-25090?

No fix has been published for CVE-2024-25090 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-25090 being exploited?

There is no known exploitation of CVE-2024-25090 in the wild and no public exploit code.

## Other vulnerabilities in Apache Roller

- [CVE-2018-17198](https://insights.sbomify.com/CVE-2018-17198/): Server-side request forgery in Apache Roller (critical 9.8)
- [CVE-2014-0030](https://insights.sbomify.com/CVE-2014-0030/): XML external entity in n/a (critical 9.8)
- [CVE-2021-33580](https://insights.sbomify.com/CVE-2021-33580/): regex injection leading to DoS (high 7.5)
- [CVE-2015-0249](https://insights.sbomify.com/CVE-2015-0249/): Code injection in n/a (high 7.2)
- [CVE-2013-4212](https://insights.sbomify.com/CVE-2013-4212/): Code injection in n/a (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-25090 and fix it if it is affected.

What it is: CVE-2024-25090 is a medium-severity cross-site scripting vulnerability in Apache Roller, published on 26 Jul 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-25090 in the wild and no public exploit code.

Affected product: Apache Roller. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-25090/ (Markdown: https://insights.sbomify.com/CVE-2024-25090/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-25090
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-25090
- OSV: https://osv.dev/vulnerability/CVE-2024-25090

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-25090/
Summaries are generated and may contain mistakes; the official description above is the record.
