{"answers":{"affected":"2 open source packages ship an affected version, including pixelfed/pixelfed. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-25108 exists.","fix":"Upgrade pixelfed/pixelfed to 0.11.11 or later.","what":"CVE-2024-25108 is a critical missing authorization vulnerability in pixelfed, published on 12 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-25108 and fix it if it is affected.\n\nWhat it is: CVE-2024-25108 is a critical missing authorization vulnerability in pixelfed, published on 12 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-25108 exists.\n\nAffected packages and fixed versions:\n- pixelfed/pixelfed (Packagist): affected from 0.10.4; fixed in 0.11.11\n- pixelfed/pixelfed (Packagist): affected from 0.10.4; fixed in 0.11.11\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-25108/ (Markdown: https://insights.sbomify.com/CVE-2024-25108/index.md)","id":"CVE-2024-25108","markdown":"https://insights.sbomify.com/CVE-2024-25108/index.md","name":"CVE-2024-25108","record":{"aliases":["GHSA-gccq-h3xj-jgvf"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Pixelfed photo sharing","requires_auth":"none","summary":"Insufficient authorization checks allow attackers to access administrative and moderator functions in Pixelfed, leading to privilege escalation.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"pixelfed","vendor":"pixelfed"}],"cvss":{"score":9.9,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"},{"id":"CWE-285","name":"Improper Authorization"},{"id":"CWE-280","name":"Improper Handling of Insufficient Permissions or Privileges"}],"description":"Pixelfed is an open source photo sharing platform. When processing requests authorization was improperly and insufficiently checked, allowing attackers to access far more functionality than users intended, including to the administrative and moderator functionality of the Pixelfed server. This vulnerability affects every version of Pixelfed between v0.10.4 and v0.11.9, inclusive. A proof of concept of this vulnerability exists. This vulnerability affects every local user of a Pixelfed server, and can potentially affect the servers' ability to federate. Some user interaction is required to setup the conditions to be able to exercise the vulnerability, but the attacker could conduct this attack time-delayed manner, where user interaction is not actively required. This vulnerability has been addressed in version 0.11.11. Users are advised to upgrade. There are no known workarounds for this vulnerability.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Insufficient authorization allowing elevated access to resources in pixelfed","id":"CVE-2024-25108","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"missing_authorization","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"Cross-Site Scripting in the extensions, settings, permissions and namespaces subpages of ManageWiki","id":"CVE-2024-25109"},"packages":[{"ecosystem":"Packagist","fixed":["0.11.11"],"introduced":["0.10.4"],"last_affected":[],"package":"pixelfed/pixelfed","purl":null,"source":"GHSA-gccq-h3xj-jgvf"},{"ecosystem":"Packagist","fixed":["0.11.11"],"introduced":["0.10.4"],"last_affected":[],"package":"pixelfed/pixelfed","purl":"pkg:composer/pixelfed/pixelfed","source":"GHSA-gccq-h3xj-jgvf"}],"prev":{"headline":"Cross-Site Scripting in WikiDiscover","id":"CVE-2024-25107"},"products":["pixelfed"],"published":"2024-02-12","related":[{"cvss_score":5.3,"headline":"Exposure of Sensitive Information to an Unauthorized Actor in pixelfed/pixelfed","id":"CVE-2023-0901","kev_date_added":null,"published":"2023-02-18"},{"cvss_score":4.3,"headline":"Improper Authorization in pixelfed/pixelfed","id":"CVE-2023-0914","kev_date_added":null,"published":"2023-02-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-05-07","vendors":["pixelfed"]},"summary":"Insufficient authorization checks allow attackers to access administrative and moderator functions in Pixelfed, leading to privilege escalation.","url":"https://insights.sbomify.com/CVE-2024-25108/"}