# CVE-2024-25108: Insufficient authorization allowing elevated access to resources in pixelfed

> Insufficient authorization checks allow attackers to access administrative and moderator functions in Pixelfed, leading to privilege escalation.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Feb 2024
- **Updated:** 7 May 2025
- **Also known as:** GHSA-gccq-h3xj-jgvf

## What is CVE-2024-25108?

CVE-2024-25108 is a critical missing authorization vulnerability in pixelfed, published on 12 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Pixelfed is an open source photo sharing platform. When processing requests authorization was improperly and insufficiently checked, allowing attackers to access far more functionality than users intended, including to the administrative and moderator functionality of the Pixelfed server. This vulnerability affects every version of Pixelfed between v0.10.4 and v0.11.9, inclusive. A proof of concept of this vulnerability exists. This vulnerability affects every local user of a Pixelfed server, and can potentially affect the servers' ability to federate. Some user interaction is required to setup the conditions to be able to exercise the vulnerability, but the attacker could conduct this attack time-delayed manner, where user interaction is not actively required. This vulnerability has been addressed in version 0.11.11. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-863 (Incorrect Authorization), CWE-285 (Improper Authorization), CWE-280 (Improper Handling of Insufficient Permissions or Privileges)

## Which versions are affected by CVE-2024-25108?

2 open source packages ship an affected version, including pixelfed/pixelfed. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pixelfed/pixelfed` | Packagist | From 0.10.4 | 0.11.11 |
| `pixelfed/pixelfed` | Packagist | From 0.10.4 | 0.11.11 |

Products: Pixelfed Pixelfed.

## How do I fix CVE-2024-25108?

Upgrade pixelfed/pixelfed to 0.11.11 or later.

## Is CVE-2024-25108 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-25108 exists.

## Other vulnerabilities in pixelfed

- [CVE-2023-0901](https://insights.sbomify.com/CVE-2023-0901/): Exposure of Sensitive Information to an Unauthorized Actor in pixelfed/pixelfed (medium 5.3)
- [CVE-2023-0914](https://insights.sbomify.com/CVE-2023-0914/): Improper Authorization in pixelfed/pixelfed (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-25108 and fix it if it is affected.

What it is: CVE-2024-25108 is a critical missing authorization vulnerability in pixelfed, published on 12 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-25108 exists.

Affected packages and fixed versions:
- pixelfed/pixelfed (Packagist): affected from 0.10.4; fixed in 0.11.11
- pixelfed/pixelfed (Packagist): affected from 0.10.4; fixed in 0.11.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-25108/ (Markdown: https://insights.sbomify.com/CVE-2024-25108/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-25108
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-25108
- OSV: https://osv.dev/vulnerability/CVE-2024-25108

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-25108/
Summaries are generated and may contain mistakes; the official description above is the record.
