# CVE-2024-25111: SQUID-2024:1 Denial of Service in HTTP Chunked Decoding

> Remote attackers can cause a denial of service in Squid web proxy by sending crafted chunked HTTP messages due to uncontrolled recursion.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Mar 2024
- **Updated:** 3 Nov 2025
- **Also known as:** AZL-42511, CLSA-2024-1712261257, CLSA-2024-1712490592, CLSA-2025-1738693764, DEBIAN-CVE-2024-25111, GHSA-72c2-c3wm-8qxc, OESA-2024-2060, OESA-2024-2206, OESA-2024-2207, OESA-2024-2208, OESA-2024-2209, RHSA-2024:1479, RHSA-2024:1515, RHSA-2024:2822, UBUNTU-CVE-2024-25111

## What is CVE-2024-25111?

CVE-2024-25111 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 6 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Squid is a web proxy cache. Starting in version 3.5.27 and prior to version 6.8, Squid may be vulnerable to a Denial of Service attack against HTTP Chunked decoder due to an uncontrolled recursion bug. This problem allows a remote attacker to cause Denial of Service when sending a crafted, chunked, encoded HTTP Message. This bug is fixed in Squid version 6.8. In addition, patches addressing this problem for the stable releases can be found in Squid's patch archives. There is no workaround for this issue.

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2024-25111?

It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libecap` | Red Hat:rhel_eus:8.6::appstream | All versions | 0:1.0.1-2.module+el8.1.0+4044+36416a77 |
| `libecap-debuginfo` | Red Hat:rhel_eus:8.6::appstream | All versions | 0:1.0.1-2.module+el8.1.0+4044+36416a77 |
| `libecap-debugsource` | Red Hat:rhel_eus:8.6::appstream | All versions | 0:1.0.1-2.module+el8.1.0+4044+36416a77 |
| `libecap-devel` | Red Hat:rhel_eus:8.6::appstream | All versions | 0:1.0.1-2.module+el8.1.0+4044+36416a77 |
| `squid` | Red Hat:rhel_eus:8.6::appstream | All versions | 7:4.15-3.module+el8.6.0+21519+58cab4c1.6 |
| `squid-debuginfo` | Red Hat:rhel_eus:8.6::appstream | All versions | 7:4.15-3.module+el8.6.0+21519+58cab4c1.6 |
| `squid-debugsource` | Red Hat:rhel_eus:8.6::appstream | All versions | 7:4.15-3.module+el8.6.0+21519+58cab4c1.6 |
| `libecap` | Red Hat:rhel_eus:8.8::appstream | All versions | 0:1.0.1-2.module+el8.1.0+4044+36416a77 |
| `libecap-debuginfo` | Red Hat:rhel_eus:8.8::appstream | All versions | 0:1.0.1-2.module+el8.1.0+4044+36416a77 |
| `libecap-debugsource` | Red Hat:rhel_eus:8.8::appstream | All versions | 0:1.0.1-2.module+el8.1.0+4044+36416a77 |
| `libecap-devel` | Red Hat:rhel_eus:8.8::appstream | All versions | 0:1.0.1-2.module+el8.1.0+4044+36416a77 |
| `squid` | Red Hat:rhel_eus:8.8::appstream | All versions | 7:4.15-6.module+el8.8.0+21509+962c493b.6 |
| `squid-debuginfo` | Red Hat:rhel_eus:8.8::appstream | All versions | 7:4.15-6.module+el8.8.0+21509+962c493b.6 |
| `squid-debugsource` | Red Hat:rhel_eus:8.8::appstream | All versions | 7:4.15-6.module+el8.8.0+21509+962c493b.6 |
| `squid` | Red Hat:rhel_eus:9.2::appstream | All versions | 7:5.5-5.el9_2.6 |
| `squid-debuginfo` | Red Hat:rhel_eus:9.2::appstream | All versions | 7:5.5-5.el9_2.6 |
| `squid-debugsource` | Red Hat:rhel_eus:9.2::appstream | All versions | 7:5.5-5.el9_2.6 |

Products: Fedoraproject Fedora, Netapp Bluexp, Squid-Cache Squid.

## How do I fix CVE-2024-25111?

Upgrade to a fixed version.

## Is CVE-2024-25111 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-25111 exists.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-25111 and fix it if it is affected.

What it is: CVE-2024-25111 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 6 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-25111 exists.

Affected product: Fedoraproject Fedora. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-25111/ (Markdown: https://insights.sbomify.com/CVE-2024-25111/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-25111
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-25111
- OSV: https://osv.dev/vulnerability/CVE-2024-25111

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-25111/
Summaries are generated and may contain mistakes; the official description above is the record.
