# CVE-2024-25112: Denial of service due to unbounded recursion in QuickTimeVideo::multipleEntriesDecoder in Exiv2

> An attacker can cause a denial of service by providing a crafted video file that triggers unbounded recursion in the Exiv2 library.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Feb 2024
- **Updated:** 1 Aug 2024
- **Also known as:** AZL-42515, AZL-42558, CLEANSTART-2024-GA74818, DEBIAN-CVE-2024-25112, GHSA-crmj-qh74-2r36, PYSEC-2024-107

## What is CVE-2024-25112?

CVE-2024-25112 is a medium-severity denial of service vulnerability in Exiv2 Exiv2, published on 12 Feb 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Exiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. A denial-of-service was found in Exiv2 version v0.28.1: an unbounded recursion can cause Exiv2 to crash by exhausting the stack. The vulnerable function, `QuickTimeVideo::multipleEntriesDecoder`, was new in v0.28.0, so Exiv2 versions before v0.28 are _not_ affected. The denial-of-service is triggered when Exiv2 is used to read the metadata of a crafted video file. This bug is fixed in version v0.28.2. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-674 (Uncontrolled Recursion), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2024-25112?

3 open source packages ship an affected version, including exiv2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `exiv2` | PyPI | From 0.16.0 | 0.16.1 |
| `exiv2` | PyPI | From 0.16.0 | 0.16.1 |
| `exiv2` | PyPI | From 0.16.0 | 0.16.1 |

Products: Exiv2 Exiv2.

## How do I fix CVE-2024-25112?

Upgrade exiv2 to 0.16.1 or later.

## Is CVE-2024-25112 being exploited?

There is no known exploitation of CVE-2024-25112 in the wild and no public exploit code.

## Other vulnerabilities in Exiv2 Exiv2

- [CVE-2023-44398](https://insights.sbomify.com/CVE-2023-44398/): Out-of-bounds write in exiv2 (high 8.8)
- [CVE-2019-9143](https://insights.sbomify.com/CVE-2019-9143/): Denial of service in n/a (high 8.8)
- [CVE-2019-9144](https://insights.sbomify.com/CVE-2019-9144/): Denial of service in n/a (high 8.8)
- [CVE-2018-14046](https://insights.sbomify.com/CVE-2018-14046/): Memory corruption in n/a (high 8.8)
- [CVE-2017-12955](https://insights.sbomify.com/CVE-2017-12955/): Memory corruption in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-25112 and fix it if it is affected.

What it is: CVE-2024-25112 is a medium-severity denial of service vulnerability in Exiv2 Exiv2, published on 12 Feb 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-25112 in the wild and no public exploit code.

Affected packages and fixed versions:
- exiv2 (PyPI): affected from 0.16.0; fixed in 0.16.1
- exiv2 (PyPI): affected from 0.16.0; fixed in 0.16.1
- exiv2 (PyPI): affected from 0.16.0; fixed in 0.16.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-25112/ (Markdown: https://insights.sbomify.com/CVE-2024-25112/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-25112
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-25112
- OSV: https://osv.dev/vulnerability/CVE-2024-25112

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-25112/
Summaries are generated and may contain mistakes; the official description above is the record.
