# CVE-2024-25115: RedisBloom heap buffer overflow in CF.LOADCHUNK command

> Authenticated users can trigger a heap buffer overflow via CF.LOADCHUNK commands, potentially leading to remote code execution.

- **Severity:** High 7.0 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 9 Apr 2024
- **Updated:** 1 Aug 2024
- **Also known as:** GHSA-w583-p2wh-4vj5

## What is CVE-2024-25115?

CVE-2024-25115 is a high-severity memory corruption vulnerability in RedisBloom, published on 9 Apr 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

RedisBloom adds a set of probabilistic data structures to Redis. Starting in version 2.0.0 and prior to version 2.4.7 and 2.6.10, specially crafted `CF.LOADCHUNK` commands may be used by authenticated users to perform heap overflow, which may lead to remote code execution. The problem is fixed in RedisBloom 2.4.7 and 2.6.10.

Weakness: CWE-122 (Heap-based Buffer Overflow), CWE-120 (Buffer Copy without Checking Size of Input)

## Which versions are affected by CVE-2024-25115?


## How do I fix CVE-2024-25115?

No fix has been published for CVE-2024-25115 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-25115 being exploited?

There is no known exploitation of CVE-2024-25115 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-25115 and fix it if it is affected.

What it is: CVE-2024-25115 is a high-severity memory corruption vulnerability in RedisBloom, published on 9 Apr 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-25115 in the wild and no public exploit code.

Affected product: RedisBloom. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-25115/ (Markdown: https://insights.sbomify.com/CVE-2024-25115/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-25115
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-25115
- OSV: https://osv.dev/vulnerability/CVE-2024-25115

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-25115/
Summaries are generated and may contain mistakes; the official description above is the record.
