# CVE-2024-25116: Specially crafted CF.RESERVE command can lead to denial-of-service

> Authenticated users can crash the Redis server by sending a specially crafted CF.RESERVE command, requiring an upgrade to patched RedisBloom versions.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 9 Apr 2024
- **Updated:** 1 Aug 2024
- **Also known as:** GHSA-wrwq-cfrx-pmg4

## What is CVE-2024-25116?

CVE-2024-25116 is a medium-severity denial of service vulnerability in RedisBloom, published on 9 Apr 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

RedisBloom adds a set of probabilistic data structures to Redis. Starting in version 2.0.0 and prior to version 2.4.7 and 2.6.10, authenticated users can use the `CF.RESERVE` command to trigger a runtime assertion and termination of the Redis server process. The problem is fixed in RedisBloom 2.4.7 and 2.6.10.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2024-25116?


## How do I fix CVE-2024-25116?

No fix has been published for CVE-2024-25116 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-25116 being exploited?

There is no known exploitation of CVE-2024-25116 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-25116 and fix it if it is affected.

What it is: CVE-2024-25116 is a medium-severity denial of service vulnerability in RedisBloom, published on 9 Apr 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-25116 in the wild and no public exploit code.

Affected product: RedisBloom. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-25116/ (Markdown: https://insights.sbomify.com/CVE-2024-25116/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-25116
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-25116
- OSV: https://osv.dev/vulnerability/CVE-2024-25116

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-25116/
Summaries are generated and may contain mistakes; the official description above is the record.
