# CVE-2024-25117: php-svg-lib lacks path validation on font through SVG inline styles

> Attackers can achieve remote code execution by injecting PHAR URLs into SVG font-family attributes, affecting applications using php-svg-lib.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Feb 2024
- **Updated:** 28 Aug 2024
- **Also known as:** DEBIAN-CVE-2024-25117, GHSA-f3qr-qr4x-j273

## What is CVE-2024-25117?

CVE-2024-25117 is a medium-severity unsafe deserialization vulnerability in dompdf php-svg-lib, published on 21 Feb 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

php-svg-lib is a scalable vector graphics (SVG) file parsing/rendering library. Prior to version 0.5.2, php-svg-lib fails to validate that font-family doesn't contain a PHAR url, which might leads to RCE on PHP < 8.0, and doesn't validate if external references are allowed. This might leads to bypass of restrictions or RCE on projects that are using it, if they do not strictly revalidate the fontName that is passed by php-svg-lib. The `Style::fromAttributes(`), or the `Style::parseCssStyle()` should check the content of the `font-family` and prevents it to use a PHAR url, to avoid passing an invalid and dangerous `fontName` value to other libraries. The same check as done in the `Style::fromStyleSheets` might be reused. Libraries using this library as a dependency might be vulnerable to some bypass of restrictions, or even remote code execution, if they do not double check the value of the `fontName` that is passed by php-svg-lib. Version 0.5.2 contains a fix for this issue.

Weakness: CWE-610 (Externally Controlled Reference to a Resource in Another Sphere), CWE-73 (External Control of File Name or Path), CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2024-25117?

2 open source packages ship an affected version, including phenx/php-svg-lib. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phenx/php-svg-lib` | Packagist | All versions | 0.5.2 |
| `phenx/php-svg-lib` | Packagist | All versions | 0.5.2 |

Products: Dompdf Php-Svg-Lib.

## How do I fix CVE-2024-25117?

Upgrade phenx/php-svg-lib to 0.5.2 or later.

## Is CVE-2024-25117 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-25117 exists.

## Other vulnerabilities in dompdf php-svg-lib

- [CVE-2023-50252](https://insights.sbomify.com/CVE-2023-50252/): php-svg-lib unsafe attributes merge when parsing `use` tag (high 8.3)
- [CVE-2023-50251](https://insights.sbomify.com/CVE-2023-50251/): php-svg-lib possible DoS caused by infinite recursion when parsing SVG document (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-25117 and fix it if it is affected.

What it is: CVE-2024-25117 is a medium-severity unsafe deserialization vulnerability in dompdf php-svg-lib, published on 21 Feb 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-25117 exists.

Affected packages and fixed versions:
- phenx/php-svg-lib (Packagist): affected all versions; fixed in 0.5.2
- phenx/php-svg-lib (Packagist): affected all versions; fixed in 0.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-25117/ (Markdown: https://insights.sbomify.com/CVE-2024-25117/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-25117
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-25117
- OSV: https://osv.dev/vulnerability/CVE-2024-25117

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-25117/
Summaries are generated and may contain mistakes; the official description above is the record.
