# CVE-2024-25124: Fiber has Insecure CORS Configuration, Allowing Wildcard Origin with Credentials

> Fiber's CORS middleware allows insecure wildcard origins with credentials, potentially exposing sensitive user data to unauthorized access.

- **Severity:** Critical 9.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Feb 2024
- **Updated:** 26 Aug 2024
- **Also known as:** GHSA-fmg4-x8pw-hjhg, GO-2024-2574

## What is CVE-2024-25124?

CVE-2024-25124 is a critical vulnerability in gofiber fiber, published on 21 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Fiber is a web framework written in go. Prior to version 2.52.1, the CORS middleware allows for insecure configurations that could potentially expose the application to multiple CORS-related vulnerabilities. Specifically, it allows setting the Access-Control-Allow-Origin header to a wildcard (`*`) while also having the Access-Control-Allow-Credentials set to true, which goes against recommended security best practices. The impact of this misconfiguration is high as it can lead to unauthorized access to sensitive user data and expose the system to various types of attacks listed in the PortSwigger article linked in the references. Version 2.52.1 contains a patch for this issue. As a workaround, users may manually validate the CORS configurations in their implementation to ensure that they do not allow a wildcard origin when credentials are enabled. The browser fetch api, as well as browsers and utilities that enforce CORS policies, are not affected by this.

Weakness: CWE-942 (Permissive Cross-domain Security Policy with Untrusted Domains), CWE-346 (Origin Validation Error)

## Which versions are affected by CVE-2024-25124?

3 open source packages ship an affected version, including github.com/gofiber/fiber/v2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/gofiber/fiber/v2` | Go | All versions | 2.52.1 |
| `github.com/gofiber/fiber/v2` | Go | All versions | 2.52.1 |
| `github.com/gofiber/fiber/v2` | Go | All versions | 2.52.1 |

Products: Gofiber Fiber.

## How do I fix CVE-2024-25124?

Upgrade github.com/gofiber/fiber/v2 to 2.52.1 or later.

## Is CVE-2024-25124 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-25124 exists.

## Other vulnerabilities in gofiber fiber

- [CVE-2024-38513](https://insights.sbomify.com/CVE-2024-38513/): Fiber Session Middleware Token Injection Vulnerability (critical 10.0)
- [CVE-2023-45128](https://insights.sbomify.com/CVE-2023-45128/): CSRF Token Reuse Vulnerability in fiber (critical 10.0)
- [CVE-2025-66630](https://insights.sbomify.com/CVE-2025-66630/): Fiber insecurely fallsback in utils.UUIDv4() / utils.UUID() — predictable / zero‑UUID on crypto/rand failure (critical 9.2)
- [CVE-2025-54801](https://insights.sbomify.com/CVE-2025-54801/): Fiber Susceptible to Crash via `BodyParser` Due to Unvalidated Large Slice Index in Decoder (high 8.7)
- [CVE-2023-45141](https://insights.sbomify.com/CVE-2023-45141/): CSRF Token Validation Vulnerability in fiber (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-25124 and fix it if it is affected.

What it is: CVE-2024-25124 is a critical vulnerability in gofiber fiber, published on 21 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-25124 exists.

Affected packages and fixed versions:
- github.com/gofiber/fiber/v2 (Go): affected all versions; fixed in 2.52.1
- github.com/gofiber/fiber/v2 (Go): affected all versions; fixed in 2.52.1
- github.com/gofiber/fiber/v2 (Go): affected all versions; fixed in 2.52.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-25124/ (Markdown: https://insights.sbomify.com/CVE-2024-25124/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-25124
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-25124
- OSV: https://osv.dev/vulnerability/CVE-2024-25124

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-25124/
Summaries are generated and may contain mistakes; the official description above is the record.
