# CVE-2024-25125: Absolute path traversal vulnerability in digdag server


- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 14 Feb 2024
- **Updated:** 14 Aug 2024
- **Also known as:** GHSA-5mp4-32rr-v3x5

## What is CVE-2024-25125?

CVE-2024-25125 is a medium-severity vulnerability in treasure-data digdag, published on 14 Feb 2024. 

### Official description

Digdag is an open source tool that to build, run, schedule, and monitor complex pipelines of tasks across various platforms. Treasure Data's digdag workload automation system is susceptible to a path traversal vulnerability if it's configured to store log files locally. This issue may lead to information disclosure and has been addressed in release version 0.10.5.1. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2024-25125?

2 open source packages ship an affected version, including io.digdag:digdag-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.digdag:digdag-server` | Maven | All versions | 0.10.5.1 |
| `io.digdag:digdag-server` | Maven | All versions | 0.10.5.1 |

Products: Treasuredata Digdag.

## How do I fix CVE-2024-25125?

Upgrade io.digdag:digdag-server to 0.10.5.1 or later.

## Is CVE-2024-25125 being exploited?

There is no known exploitation of CVE-2024-25125 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-25125 and fix it if it is affected.

What it is: CVE-2024-25125 is a medium-severity vulnerability in treasure-data digdag, published on 14 Feb 2024. 
Exploitation: There is no known exploitation of CVE-2024-25125 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.digdag:digdag-server (Maven): affected all versions; fixed in 0.10.5.1
- io.digdag:digdag-server (Maven): affected all versions; fixed in 0.10.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-25125/ (Markdown: https://insights.sbomify.com/CVE-2024-25125/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-25125
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-25125
- OSV: https://osv.dev/vulnerability/CVE-2024-25125

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-25125/
Summaries are generated and may contain mistakes; the official description above is the record.
