{"answers":{"affected":"3 open source packages ship an affected version, including flask-appbuilder and Flask-AppBuilder. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-25128 in the wild and no public exploit code.","fix":"Upgrade flask-appbuilder to 4.3.11 or later.","what":"CVE-2024-25128 is a critical vulnerability in dpgaspar Flask-AppBuilder, published on 28 Feb 2024."},"fix_prompt":"Check this codebase for CVE-2024-25128 and fix it if it is affected.\n\nWhat it is: CVE-2024-25128 is a critical vulnerability in dpgaspar Flask-AppBuilder, published on 28 Feb 2024. \nExploitation: There is no known exploitation of CVE-2024-25128 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- flask-appbuilder (PyPI): affected all versions; fixed in 4.3.11\n- flask-appbuilder (PyPI): affected all versions; fixed in 4.3.11\n- Flask-AppBuilder (PyPI): affected all versions; fixed in 4.3.11\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-25128/ (Markdown: https://insights.sbomify.com/CVE-2024-25128/index.md)","id":"CVE-2024-25128","markdown":"https://insights.sbomify.com/CVE-2024-25128/index.md","name":"CVE-2024-25128","record":{"aliases":["ECHO-52c1-f769-b858","GHSA-j2pw-vp55-fqqj","PYSEC-2026-340","ROOT-APP-PYPI-CVE-2024-25128"],"analysis":null,"analysis_generated_by":null,"assigner":"GitHub_M","cpe":[{"product":"flask-appbuilder","vendor":"dpgaspar"}],"cvss":{"score":9.1,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"Flask-AppBuilder is an application development framework, built on top of Flask. When Flask-AppBuilder is set to AUTH_TYPE AUTH_OID, it allows an attacker to forge an HTTP request, that could deceive the backend into using any requested OpenID service. This vulnerability could grant an attacker unauthorised privilege access if a custom OpenID service is deployed by the attacker and accessible by the backend. This vulnerability is only exploitable when the application is using the OpenID 2.0 authorization protocol. Upgrade to Flask-AppBuilder 4.3.11 to fix the vulnerability.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Flask-AppBuilder incorrect authentication when using auth type OpenID","id":"CVE-2024-25128","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":null,"year":"2024"},"n_packages":3,"n_references":2,"next":{"headline":"Limited data exfiltration in CodeQL CLI","id":"CVE-2024-25129"},"packages":[{"ecosystem":"PyPI","fixed":["4.3.11"],"introduced":["0"],"last_affected":[],"package":"Flask-AppBuilder","purl":null,"source":"GHSA-j2pw-vp55-fqqj"},{"ecosystem":"PyPI","fixed":["4.3.11"],"introduced":["0"],"last_affected":[],"package":"flask-appbuilder","purl":"pkg:pypi/flask-appbuilder","source":"GHSA-j2pw-vp55-fqqj"},{"ecosystem":"PyPI","fixed":["4.3.11"],"introduced":["0"],"last_affected":[],"package":"flask-appbuilder","purl":"pkg:pypi/flask-appbuilder","source":"PYSEC-2026-340"}],"prev":{"headline":"Rack ReDos in content type parsing (2nd degree polynomial)","id":"CVE-2024-25126"},"products":["Flask-AppBuilder"],"published":"2024-02-28","related":[{"cvss_score":8.1,"headline":"Improper Authentication in Flask-AppBuilder","id":"CVE-2021-41265","kev_date_added":null,"published":"2021-12-09"},{"cvss_score":7.5,"headline":"No Rate Limiting on Login AUTH DB","id":"CVE-2023-29005","kev_date_added":null,"published":"2023-04-10"},{"cvss_score":7.2,"headline":"URL Redirection to Untrusted Site ('Open Redirect') in Flask-AppBuilder","id":"CVE-2021-32805","kev_date_added":null,"published":"2021-09-08"},{"cvss_score":6.5,"headline":"Flask App Builder has an Authentication Bypass vulnerability when using non AUTH_DB methods","id":"CVE-2025-58065","kev_date_added":null,"published":"2025-09-11"},{"cvss_score":6.1,"headline":"Open Redirect in Flask-AppBuilder","id":"CVE-2022-24776","kev_date_added":null,"published":"2022-03-24"},{"cvss_score":5.3,"headline":"Observable Response Discrepancy in Flask-AppBuilder","id":"CVE-2022-21659","kev_date_added":null,"published":"2022-01-31"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-08-26","vendors":["dpgaspar"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2024-25128/"}