# CVE-2024-25141: Improper Certificate Validation in apache airflow mongo hook

> Attackers can bypass SSL certificate validation in Apache Airflow Mongo Provider when SSL is enabled, allowing man-in-the-middle attacks.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Feb 2024
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-x5pm-h33q-cjrw, PYSEC-2026-278

## What is CVE-2024-25141?

CVE-2024-25141 is a critical vulnerability in Apache Airflow Mongo Provider, published on 20 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

When ssl was enabled for Mongo Hook, default settings included "allow_insecure" which caused that certificates were not validated. This was unexpected and undocumented.
Users are recommended to upgrade to version 4.0.0, which fixes this issue.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2024-25141?

3 open source packages ship an affected version, including apache-airflow-providers-mongo. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow-providers-mongo` | PyPI | All versions | 4.0.0 |
| `apache-airflow-providers-mongo` | PyPI | All versions | 4.0.0 |
| `apache-airflow-providers-mongo` | PyPI | All versions | 4.0.0 |

Products: Apache Apache-Airflow-Providers-Mongo.

## How do I fix CVE-2024-25141?

Upgrade apache-airflow-providers-mongo to 4.0.0 or later.

## Is CVE-2024-25141 being exploited?

There is no known exploitation of CVE-2024-25141 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-25141 and fix it if it is affected.

What it is: CVE-2024-25141 is a critical vulnerability in Apache Airflow Mongo Provider, published on 20 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-25141 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow-providers-mongo (PyPI): affected all versions; fixed in 4.0.0
- apache-airflow-providers-mongo (PyPI): affected all versions; fixed in 4.0.0
- apache-airflow-providers-mongo (PyPI): affected all versions; fixed in 4.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-25141/ (Markdown: https://insights.sbomify.com/CVE-2024-25141/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-25141
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-25141
- OSV: https://osv.dev/vulnerability/CVE-2024-25141

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-25141/
Summaries are generated and may contain mistakes; the official description above is the record.
