# CVE-2024-25142: Apache Airflow: Cache Control - Storage of Sensitive Data in Browser Cache

> Apache Airflow failed to set Cache-Control headers, potentially allowing sensitive data to be stored in browser caches and exposed to attackers.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jun 2024
- **Updated:** 20 Mar 2025
- **Also known as:** BIT-airflow-2024-25142, ECHO-6361-2016-a1d1, GHSA-9xpj-62mm-24h2, PYSEC-2024-195

## What is CVE-2024-25142?

CVE-2024-25142 is a medium-severity vulnerability in Apache Airflow, published on 14 Jun 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Use of Web Browser Cache Containing Sensitive Information vulnerability in Apache Airflow. 

Airflow did not return "Cache-Control" header for dynamic content, which in case of some browsers could result in potentially storing sensitive data in local cache of the browser.

This issue affects Apache Airflow: before 2.9.2.

Users are recommended to upgrade to version 2.9.2, which fixes the issue.

Weakness: CWE-525 (Use of Web Browser Cache Containing Sensitive Information)

## Which versions are affected by CVE-2024-25142?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | All versions | 2.9.2 |
| `apache-airflow` | PyPI | All versions | 2.9.2 |
| `apache-airflow` | PyPI | All versions | 2.9.2 |
| `airflow` | Bitnami | All versions | 2.9.2 |

Products: Apache Airflow.

## How do I fix CVE-2024-25142?

Upgrade apache-airflow to 2.9.2 or later.

## Is CVE-2024-25142 being exploited?

There is no known exploitation of CVE-2024-25142 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-25142 and fix it if it is affected.

What it is: CVE-2024-25142 is a medium-severity vulnerability in Apache Airflow, published on 14 Jun 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-25142 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected all versions; fixed in 2.9.2
- apache-airflow (PyPI): affected all versions; fixed in 2.9.2
- apache-airflow (PyPI): affected all versions; fixed in 2.9.2
- airflow (Bitnami): affected all versions; fixed in 2.9.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-25142/ (Markdown: https://insights.sbomify.com/CVE-2024-25142/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-25142
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-25142
- OSV: https://osv.dev/vulnerability/CVE-2024-25142

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-25142/
Summaries are generated and may contain mistakes; the official description above is the record.
