CVE-2024-25144 Liferay Portal denial-of-service vulnerability
Authenticated users can cause denial of service in Liferay Portal by creating a self-referencing IFrame widget.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2024-25144?
CVE-2024-25144 is a medium-severity denial of service vulnerability in Liferay Digital Experience Platform, published on 8 Feb 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
The IFrame widget in Liferay Portal 7.2.0 through 7.4.3.26, and older unsupported versions, and Liferay DXP 7.4 before update 27, 7.3 before update 6, 7.2 before fix pack 19, and older unsupported versions does not check the URL of the IFrame, which allows remote authenticated users to cause a denial-of-service (DoS) via a self referencing IFrame.
Which versions are affected by CVE-2024-25144?
8 open source packages ship an affected version, including com.liferay.portal:release.dxp.bom and com.liferay.portal:release.portal.bom. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
com.liferay.portal:release.dxp.bom Maven | From 7.2.0 | 7.2.10.fp19 |
com.liferay.portal:release.dxp.bom Maven | From 7.2.0 | 7.2.10.fp19 |
com.liferay.portal:release.dxp.bom Maven | From 7.3.0 | 7.3.10.u6 |
com.liferay.portal:release.dxp.bom Maven | From 7.3.0 | 7.3.10.u6 |
com.liferay.portal:release.dxp.bom Maven | From 7.4.0 | 7.4.13.u27 |
com.liferay.portal:release.dxp.bom Maven | From 7.4.0 | 7.4.13.u27 |
2 more packages
com.liferay.portal:release.portal.bom Maven | From 7.2.0 | 7.4.3.27 |
com.liferay.portal:release.portal.bom Maven | From 7.2.0 | 7.4.3.27 |
Products include Liferay Digital Experience Platform, Liferay Dxp, Liferay Liferay Portal.
How do I fix CVE-2024-25144?
Upgrade com.liferay.portal:release.dxp.bom to a fixed version for your release line: 7.2.10.fp19, 7.3.10.u6 or 7.4.13.u27.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2024-25144 being exploited?
There is no known exploitation of CVE-2024-25144 in the wild and no public exploit code.
Other vulnerabilities in Liferay Digital Experience Platform
- CVE-2024-8980 Liferay Portal and Liferay DXP Vulnerable to CSRF in the Script Console
- CVE-2023-42496 Liferay Portal and Liferay DXP vulnerable to reflected Cross-site Scripting
- CVE-2023-42498 Liferay Portal Language Override edit screen and Liferay DXP vulnerable to reflected Cross-site Scripting
- CVE-2024-25147 Liferay Portal and Liferay DXP vulnerable to Cross-site Scripting
- CVE-2024-26269 Liferay Portal Frontend JS module's portlet.js and Liferay DXP vulnerable to Cross-site Scripting
Sources
Also known as GHSA-w275-m8cr-hf2v.