# CVE-2024-25144: Liferay Portal denial-of-service vulnerability

> Authenticated users can cause denial of service in Liferay Portal by creating a self-referencing IFrame widget.

- **Severity:** Medium 4.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Feb 2024
- **Updated:** 2 Oct 2024
- **Also known as:** GHSA-w275-m8cr-hf2v

## What is CVE-2024-25144?

CVE-2024-25144 is a medium-severity denial of service vulnerability in Liferay Digital Experience Platform, published on 8 Feb 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

The IFrame widget in Liferay Portal 7.2.0 through 7.4.3.26, and older unsupported versions, and Liferay DXP 7.4 before update 27, 7.3 before update 6, 7.2 before fix pack 19, and older unsupported versions does not check the URL of the IFrame, which allows remote authenticated users to cause a denial-of-service (DoS) via a self referencing IFrame.

Weakness: CWE-834 (Excessive Iteration), CWE-835 (Loop with Unreachable Exit Condition)

## Which versions are affected by CVE-2024-25144?

8 open source packages ship an affected version, including com.liferay.portal:release.dxp.bom and com.liferay.portal:release.portal.bom. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.liferay.portal:release.dxp.bom` | Maven | From 7.2.0 | 7.2.10.fp19 |
| `com.liferay.portal:release.dxp.bom` | Maven | From 7.2.0 | 7.2.10.fp19 |
| `com.liferay.portal:release.dxp.bom` | Maven | From 7.3.0 | 7.3.10.u6 |
| `com.liferay.portal:release.dxp.bom` | Maven | From 7.3.0 | 7.3.10.u6 |
| `com.liferay.portal:release.dxp.bom` | Maven | From 7.4.0 | 7.4.13.u27 |
| `com.liferay.portal:release.dxp.bom` | Maven | From 7.4.0 | 7.4.13.u27 |
| `com.liferay.portal:release.portal.bom` | Maven | From 7.2.0 | 7.4.3.27 |
| `com.liferay.portal:release.portal.bom` | Maven | From 7.2.0 | 7.4.3.27 |

Products: Liferay Digital Experience Platform, Liferay Dxp, Liferay Liferay Portal.

## How do I fix CVE-2024-25144?

Upgrade com.liferay.portal:release.dxp.bom to a fixed version for your release line: 7.2.10.fp19, 7.3.10.u6 or 7.4.13.u27.

## Is CVE-2024-25144 being exploited?

There is no known exploitation of CVE-2024-25144 in the wild and no public exploit code.

## Other vulnerabilities in Liferay Digital Experience Platform

- [CVE-2024-8980](https://insights.sbomify.com/CVE-2024-8980/): Liferay Portal and Liferay DXP Vulnerable to CSRF in the Script Console (critical 9.6)
- [CVE-2023-42496](https://insights.sbomify.com/CVE-2023-42496/): Liferay Portal and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2023-42498](https://insights.sbomify.com/CVE-2023-42498/): Liferay Portal Language Override edit screen and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2024-25147](https://insights.sbomify.com/CVE-2024-25147/): Liferay Portal and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)
- [CVE-2024-26269](https://insights.sbomify.com/CVE-2024-26269/): Liferay Portal Frontend JS module's portlet.js and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-25144 and fix it if it is affected.

What it is: CVE-2024-25144 is a medium-severity denial of service vulnerability in Liferay Digital Experience Platform, published on 8 Feb 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-25144 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.liferay.portal:release.dxp.bom (Maven): affected from 7.2.0; fixed in 7.2.10.fp19
- com.liferay.portal:release.dxp.bom (Maven): affected from 7.2.0; fixed in 7.2.10.fp19
- com.liferay.portal:release.dxp.bom (Maven): affected from 7.3.0; fixed in 7.3.10.u6
- com.liferay.portal:release.dxp.bom (Maven): affected from 7.3.0; fixed in 7.3.10.u6
- com.liferay.portal:release.dxp.bom (Maven): affected from 7.4.0; fixed in 7.4.13.u27
- com.liferay.portal:release.dxp.bom (Maven): affected from 7.4.0; fixed in 7.4.13.u27
- com.liferay.portal:release.portal.bom (Maven): affected from 7.2.0; fixed in 7.4.3.27
- com.liferay.portal:release.portal.bom (Maven): affected from 7.2.0; fixed in 7.4.3.27

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-25144/ (Markdown: https://insights.sbomify.com/CVE-2024-25144/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-25144
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-25144
- OSV: https://osv.dev/vulnerability/CVE-2024-25144

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-25144/
Summaries are generated and may contain mistakes; the official description above is the record.
