{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-25580 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2024-25580 is a medium-severity memory corruption vulnerability in Qt Qt, published on 27 Mar 2024. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-25580 and fix it if it is affected.\n\nWhat it is: CVE-2024-25580 is a medium-severity memory corruption vulnerability in Qt Qt, published on 27 Mar 2024. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-25580 in the wild and no public exploit code.\n\nAffected product: Qt Qt. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-25580/ (Markdown: https://insights.sbomify.com/CVE-2024-25580/index.md)","id":"CVE-2024-25580","markdown":"https://insights.sbomify.com/CVE-2024-25580/index.md","name":"CVE-2024-25580","record":{"aliases":["AZL-36915","AZL-38737","DEBIAN-CVE-2024-25580","GHSA-2952-j2hp-678j","UBUNTU-CVE-2024-25580","USN-7923-1","openSUSE-SU-2024:13690-1","openSUSE-SU-2024:13775-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Qt GUI library","requires_auth":"none","summary":"A buffer overflow in the Qt library allows attackers to cause a denial of service via a crafted KTX image file.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"qt","vendor":"qt"}],"cvss":{"score":6.2,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-120","name":"Buffer Copy without Checking Size of Input"}],"description":"An issue was discovered in gui/util/qktxhandler.cpp in Qt before 5.15.17, 6.x before 6.2.12, 6.3.x through 6.5.x before 6.5.5, and 6.6.x before 6.6.2. A buffer overflow and application crash can occur via a crafted KTX image file.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Memory corruption in n/a","id":"CVE-2024-25580","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"qt:qt","products":["qt:qt"],"type":"memory_corruption","year":"2024"},"n_packages":2,"n_references":1,"next":{"headline":"Transfer requests received over DoH can lead to a denial of service in DNSdist","id":"CVE-2024-25581"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["5.15.12+kde151-1.1"],"introduced":["0"],"last_affected":[],"package":"libqt5-qtbase","purl":"pkg:rpm/opensuse/libqt5-qtbase\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:13690-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["6.6.2-2.1"],"introduced":["0"],"last_affected":[],"package":"qt6-base","purl":"pkg:rpm/opensuse/qt6-base\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:13775-1"}],"prev":{"headline":"Command injection in WMC-2LX2-B","id":"CVE-2024-25579"},"products":["n/a"],"published":"2024-03-27","related":[{"cvss_score":9.8,"headline":"Use after free in n/a","id":"CVE-2020-12267","kev_date_added":null,"published":"2020-04-27"},{"cvss_score":9.8,"headline":"Command injection in Qt for Android","id":"CVE-2017-10904","kev_date_added":null,"published":"2017-12-15"},{"cvss_score":9.3,"headline":"Memory corruption in n/a","id":"CVE-2011-3194","kev_date_added":null,"published":"2012-06-16"},{"cvss_score":8.8,"headline":"Integer overflow in Qt","id":"CVE-2022-40983","kev_date_added":null,"published":"2023-01-12"},{"cvss_score":8.8,"headline":"Memory corruption in Qt","id":"CVE-2022-43591","kev_date_added":null,"published":"2023-01-12"},{"cvss_score":8.6,"headline":"Race condition in n/a","id":"CVE-2024-39936","kev_date_added":null,"published":"2024-07-04"},{"cvss_score":8.6,"headline":"Denial of service in n/a","id":"CVE-2018-21035","kev_date_added":null,"published":"2020-02-28"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-04","vendors":["n/a"]},"summary":"A buffer overflow in the Qt library allows attackers to cause a denial of service via a crafted KTX image file.","url":"https://insights.sbomify.com/CVE-2024-25580/"}