CVE-2024-25602 Liferay Portal and Liferay DXP's Users Admin module vulnerable to stored Cross-site Scripting
Authenticated attackers can inject malicious scripts via the organization name field in Liferay Portal, potentially compromising user sessions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2024-25602?
CVE-2024-25602 is a critical cross-site scripting vulnerability in Liferay Digital Experience Platform, published on 21 Feb 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Stored cross-site scripting (XSS) vulnerability in Users Admin module's edit user page in Liferay Portal 7.2.0 through 7.4.2, and older unsupported versions, and Liferay DXP 7.3 before service pack 3, 7.2 before fix pack 17, and older unsupported versions allows remote authenticated users to inject arbitrary web script or HTML via a crafted payload injected into an organization’s “Name” text field
Weakness: CWE-79
Which versions are affected by CVE-2024-25602?
6 open source packages ship an affected version, including com.liferay.portal:release.dxp.bom and com.liferay.portal:release.portal.bom. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
com.liferay.portal:release.dxp.bom Maven | From 7.2.0 | 7.2.10.fp17 |
com.liferay.portal:release.dxp.bom Maven | From 7.2.0 | 7.2.10.fp17 |
com.liferay.portal:release.dxp.bom Maven | From 7.3.0 | 7.3.10.u4 |
com.liferay.portal:release.dxp.bom Maven | From 7.3.0 | 7.3.10.u4 |
com.liferay.portal:release.portal.bom Maven | All versions to 7.4.2 | None |
com.liferay.portal:release.portal.bom Maven | All versions to 7.4.2 | None |
Products include Liferay Digital Experience Platform, Liferay Liferay Portal.
How do I fix CVE-2024-25602?
Upgrade com.liferay.portal:release.dxp.bom to a fixed version for your release line: 7.2.10.fp17 or 7.3.10.u4.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2024-25602 being exploited?
There is no known exploitation of CVE-2024-25602 in the wild and no public exploit code.
Other vulnerabilities in Liferay Digital Experience Platform
- CVE-2024-8980 Liferay Portal and Liferay DXP Vulnerable to CSRF in the Script Console
- CVE-2023-42496 Liferay Portal and Liferay DXP vulnerable to reflected Cross-site Scripting
- CVE-2023-42498 Liferay Portal Language Override edit screen and Liferay DXP vulnerable to reflected Cross-site Scripting
- CVE-2024-25147 Liferay Portal and Liferay DXP vulnerable to Cross-site Scripting
- CVE-2024-26269 Liferay Portal Frontend JS module's portlet.js and Liferay DXP vulnerable to Cross-site Scripting
Sources
Also known as GHSA-v2xq-m22w-jmpr.