# CVE-2024-25605: Liferay Portal and Liferay DXP Allows Templates to be Viewed via the UI or API

> Remote attackers can view web content templates due to default guest permissions, exposing sensitive template data.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Feb 2024
- **Updated:** 24 Apr 2025
- **Also known as:** GHSA-mf8h-grfg-j9j3

## What is CVE-2024-25605?

CVE-2024-25605 is a medium-severity missing authorization vulnerability in Liferay Digital Experience Platform, published on 20 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Journal module in Liferay Portal 7.2.0 through 7.4.3.4, and older unsupported versions, and Liferay DXP 7.4.13, 7.3 before service pack 3, 7.2 before fix pack 17, and older unsupported versions grants guest users view permission to web content templates by default, which allows remote attackers to view any template via the UI or API.

Weakness: CWE-276 (Incorrect Default Permissions)

## Which versions are affected by CVE-2024-25605?

4 open source packages ship an affected version, including com.liferay.portal:release.dxp.bom and com.liferay.portal:release.portal.bom. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.liferay.portal:release.dxp.bom` | Maven | All versions | 7.2.10.fp17 |
| `com.liferay.portal:release.dxp.bom` | Maven | All versions | 7.2.10.fp17 |
| `com.liferay.portal:release.portal.bom` | Maven | From 7.2.0 | 7.4.3.5-ga5 |
| `com.liferay.portal:release.portal.bom` | Maven | From 7.2.0 | 7.4.3.5-ga5 |

Products: Liferay Digital Experience Platform, Liferay Liferay Portal.

## How do I fix CVE-2024-25605?

Upgrade com.liferay.portal:release.dxp.bom to 7.2.10.fp17 or later.

## Is CVE-2024-25605 being exploited?

There is no known exploitation of CVE-2024-25605 in the wild and no public exploit code.

## Other vulnerabilities in Liferay Digital Experience Platform

- [CVE-2024-8980](https://insights.sbomify.com/CVE-2024-8980/): Liferay Portal and Liferay DXP Vulnerable to CSRF in the Script Console (critical 9.6)
- [CVE-2023-42496](https://insights.sbomify.com/CVE-2023-42496/): Liferay Portal and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2023-42498](https://insights.sbomify.com/CVE-2023-42498/): Liferay Portal Language Override edit screen and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2024-25147](https://insights.sbomify.com/CVE-2024-25147/): Liferay Portal and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)
- [CVE-2024-26269](https://insights.sbomify.com/CVE-2024-26269/): Liferay Portal Frontend JS module's portlet.js and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-25605 and fix it if it is affected.

What it is: CVE-2024-25605 is a medium-severity missing authorization vulnerability in Liferay Digital Experience Platform, published on 20 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-25605 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.liferay.portal:release.dxp.bom (Maven): affected all versions; fixed in 7.2.10.fp17
- com.liferay.portal:release.dxp.bom (Maven): affected all versions; fixed in 7.2.10.fp17
- com.liferay.portal:release.portal.bom (Maven): affected from 7.2.0; fixed in 7.4.3.5-ga5
- com.liferay.portal:release.portal.bom (Maven): affected from 7.2.0; fixed in 7.4.3.5-ga5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-25605/ (Markdown: https://insights.sbomify.com/CVE-2024-25605/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-25605
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-25605
- OSV: https://osv.dev/vulnerability/CVE-2024-25605

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-25605/
Summaries are generated and may contain mistakes; the official description above is the record.
