CVE-2024-25610 Liferay Portal has a Stored XSS with Blog entries (Insecure defaults)
Authenticated users can inject arbitrary scripts into blog entries due to lack of sanitization, potentially leading to session hijacking or malicious actions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2024-25610?
CVE-2024-25610 is a critical cross-site scripting vulnerability in Liferay Digital Experience Platform, published on 20 Feb 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
In Liferay Portal 7.2.0 through 7.4.3.12, and older unsupported versions, and Liferay DXP 7.4 before update 9, 7.3 before update 4, 7.2 before fix pack 19, and older unsupported versions, the default configuration does not sanitize blog entries of JavaScript, which allows remote authenticated users to inject arbitrary web script or HTML (XSS) via a crafted payload injected into a blog entry’s content text field.
Weakness: CWE-1188
Which versions are affected by CVE-2024-25610?
10 open source packages ship an affected version, including com.liferay.portal:release.dxp.bom, com.liferay.portal:com.liferay.portal.web and com.liferay.portal:release.portal.bom. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
com.liferay.portal:release.dxp.bom Maven | All versions | 7.2.10.fp19 |
com.liferay.portal:release.dxp.bom Maven | All versions | 7.2.10.fp19 |
com.liferay.portal:release.dxp.bom Maven | From 7.3.0 | 7.3.10.u4 |
com.liferay.portal:release.dxp.bom Maven | From 7.3.0 | 7.3.10.u4 |
com.liferay.portal:release.dxp.bom Maven | From 7.4.0 | 7.4.13.u9 |
com.liferay.portal:release.dxp.bom Maven | From 7.4.0 | 7.4.13.u9 |
4 more packages
com.liferay.portal:com.liferay.portal.web Maven | All versions | 5.0.96 |
com.liferay.portal:com.liferay.portal.web Maven | All versions | 5.0.96 |
com.liferay.portal:release.portal.bom Maven | All versions | 7.4.3.13 |
com.liferay.portal:release.portal.bom Maven | All versions | 7.4.3.13 |
Products include Liferay Digital Experience Platform, Liferay Liferay Portal.
How do I fix CVE-2024-25610?
Upgrade com.liferay.portal:release.dxp.bom to a fixed version for your release line: 7.2.10.fp19, 7.3.10.u4 or 7.4.13.u9.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2024-25610 being exploited?
There is no known exploitation of CVE-2024-25610 in the wild and no public exploit code.
Other vulnerabilities in Liferay Digital Experience Platform
- CVE-2024-8980 Liferay Portal and Liferay DXP Vulnerable to CSRF in the Script Console
- CVE-2023-42496 Liferay Portal and Liferay DXP vulnerable to reflected Cross-site Scripting
- CVE-2023-42498 Liferay Portal Language Override edit screen and Liferay DXP vulnerable to reflected Cross-site Scripting
- CVE-2024-25147 Liferay Portal and Liferay DXP vulnerable to Cross-site Scripting
- CVE-2024-26269 Liferay Portal Frontend JS module's portlet.js and Liferay DXP vulnerable to Cross-site Scripting
Sources
Also known as GHSA-vvpf-53qx-cxhh.