# CVE-2024-25617: Denial of Service in HTTP Header parser in squid proxy


- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 14 Feb 2024
- **Updated:** 13 Feb 2025
- **Also known as:** AZL-42503, CLSA-2024-1710436449, CLSA-2024-1710436895, CLSA-2024-1710436968, CLSA-2024-1710789017, CLSA-2024-1711491615, CLSA-2024-1711492242, CLSA-2025-1737153705, CLSA-2025-1737153996, DEBIAN-CVE-2024-25617, GHSA-h5x6-w8mv-xfpr, OESA-2024-1162, RHSA-2024:1062, RHSA-2024:1066, RHSA-2024:1184, UBUNTU-CVE-2024-25617

## What is CVE-2024-25617?

CVE-2024-25617 is a medium-severity vulnerability in Squid-Cache Squid, published on 14 Feb 2024. 

### Official description

Squid is an open source caching proxy for the Web supporting HTTP, HTTPS, FTP, and more. Due to a Collapse of Data into Unsafe Value bug ,Squid may be vulnerable to a Denial of Service attack against HTTP header parsing. This problem allows a remote client or a remote server to perform Denial of Service when sending oversized headers in HTTP messages. In versions of Squid prior to 6.5 this can be achieved if the request_header_max_size or reply_header_max_size settings are unchanged from the default. In Squid version 6.5 and later, the default setting of these parameters is safe. Squid will emit a critical warning in cache.log if the administrator is setting these parameters to unsafe values. Squid will not at this time prevent these settings from being changed to unsafe values. Users are advised to upgrade to version 6.5. There are no known workarounds for this vulnerability. This issue is also tracked as SQUID-2024:2

Weakness: CWE-400 (Uncontrolled Resource Consumption), CWE-182 (Collapse of Data into Unsafe Value)

## Which versions are affected by CVE-2024-25617?

It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libecap` | Red Hat:rhel_eus:8.6::appstream | All versions | 0:1.0.1-2.module+el8.1.0+4044+36416a77 |
| `libecap-debuginfo` | Red Hat:rhel_eus:8.6::appstream | All versions | 0:1.0.1-2.module+el8.1.0+4044+36416a77 |
| `libecap-debugsource` | Red Hat:rhel_eus:8.6::appstream | All versions | 0:1.0.1-2.module+el8.1.0+4044+36416a77 |
| `libecap-devel` | Red Hat:rhel_eus:8.6::appstream | All versions | 0:1.0.1-2.module+el8.1.0+4044+36416a77 |
| `squid` | Red Hat:rhel_eus:8.6::appstream | All versions | 7:4.15-3.module+el8.6.0+21376+425c674a.5 |
| `squid-debuginfo` | Red Hat:rhel_eus:8.6::appstream | All versions | 7:4.15-3.module+el8.6.0+21376+425c674a.5 |
| `squid-debugsource` | Red Hat:rhel_eus:8.6::appstream | All versions | 7:4.15-3.module+el8.6.0+21376+425c674a.5 |
| `libecap` | Red Hat:rhel_eus:8.8::appstream | All versions | 0:1.0.1-2.module+el8.1.0+4044+36416a77 |
| `libecap-debuginfo` | Red Hat:rhel_eus:8.8::appstream | All versions | 0:1.0.1-2.module+el8.1.0+4044+36416a77 |
| `libecap-debugsource` | Red Hat:rhel_eus:8.8::appstream | All versions | 0:1.0.1-2.module+el8.1.0+4044+36416a77 |
| `libecap-devel` | Red Hat:rhel_eus:8.8::appstream | All versions | 0:1.0.1-2.module+el8.1.0+4044+36416a77 |
| `squid` | Red Hat:rhel_eus:8.8::appstream | All versions | 7:4.15-6.module+el8.8.0+21374+5b4927f1.4 |
| `squid-debuginfo` | Red Hat:rhel_eus:8.8::appstream | All versions | 7:4.15-6.module+el8.8.0+21374+5b4927f1.4 |
| `squid-debugsource` | Red Hat:rhel_eus:8.8::appstream | All versions | 7:4.15-6.module+el8.8.0+21374+5b4927f1.4 |
| `squid` | Red Hat:rhel_eus:9.2::appstream | All versions | 7:5.5-5.el9_2.5 |
| `squid-debuginfo` | Red Hat:rhel_eus:9.2::appstream | All versions | 7:5.5-5.el9_2.5 |
| `squid-debugsource` | Red Hat:rhel_eus:9.2::appstream | All versions | 7:5.5-5.el9_2.5 |

Products: Netapp Bluexp, Squid-Cache Squid.

## How do I fix CVE-2024-25617?

Upgrade to a fixed version.

## Is CVE-2024-25617 being exploited?

There is no known exploitation of CVE-2024-25617 in the wild and no public exploit code.

## Other vulnerabilities in Squid-Cache Squid

- [CVE-2024-21145](https://insights.sbomify.com/CVE-2024-21145/): Security feature bypass in Java SE JDK and JRE (medium 4.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-25617 and fix it if it is affected.

What it is: CVE-2024-25617 is a medium-severity vulnerability in Squid-Cache Squid, published on 14 Feb 2024. 
Exploitation: There is no known exploitation of CVE-2024-25617 in the wild and no public exploit code.

Affected product: Squid-Cache Squid. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-25617/ (Markdown: https://insights.sbomify.com/CVE-2024-25617/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-25617
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-25617
- OSV: https://osv.dev/vulnerability/CVE-2024-25617

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-25617/
Summaries are generated and may contain mistakes; the official description above is the record.
