# CVE-2024-25620: Dependency management path traversal in helm

> Attackers can save Helm charts outside intended directories by manipulating chart names, potentially overwriting files or disrupting deployments.

- **Severity:** Medium 6.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Feb 2024
- **Updated:** 26 Aug 2024
- **Also known as:** AZL-34355, AZL-34583, AZL-38023, BIT-helm-2024-25620, CLEANSTART-2026-PX46795, GHSA-v53g-5gjp-272r, GO-2024-2554, UBUNTU-CVE-2024-25620, openSUSE-SU-2024:13714-1

## What is CVE-2024-25620?

CVE-2024-25620 is a medium-severity path traversal vulnerability in helm, published on 14 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Helm is a tool for managing Charts. Charts are packages of pre-configured Kubernetes resources. When either the Helm client or SDK is used to save a chart whose name within the `Chart.yaml` file includes a relative path change, the chart would be saved outside its expected directory based on the changes in the relative path. The validation and linting did not detect the path changes in the name. This issue has been resolved in Helm v3.14.1. Users unable to upgrade should check all charts used by Helm for path changes in their name as found in the `Chart.yaml` file. This includes dependencies.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2024-25620?

4 open source packages ship an affected version, including helm.sh/helm/v3 and helm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `helm.sh/helm/v3` | Go | All versions | 3.14.1 |
| `helm.sh/helm/v3` | Go | All versions | 3.14.1 |
| `helm.sh/helm/v3` | Go | All versions | 3.14.1 |
| `helm` | Bitnami | All versions | 3.14.1 |
| `helm` | openSUSE:Tumbleweed | All versions | 3.14.2-2.1 |

Products: Helm Helm.

## How do I fix CVE-2024-25620?

Upgrade helm.sh/helm/v3 to 3.14.1 or later.

## Is CVE-2024-25620 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-25620 exists.

## Other vulnerabilities in helm

- [CVE-2019-18658](https://insights.sbomify.com/CVE-2019-18658/): Helm Unsafe Link Following (critical 9.8)
- [CVE-2019-1010275](https://insights.sbomify.com/CVE-2019-1010275/): Helm Improper Certificate Validation (critical 9.8)
- [CVE-2019-25210](https://insights.sbomify.com/CVE-2019-25210/): Information disclosure in n/a (critical 9.1)
- [CVE-2025-53547](https://insights.sbomify.com/CVE-2025-53547/): Helm Chart Dependency Updating With Malicious Chart.yaml Content And Symlink Can Lead To Code Execution (high 8.5)
- [CVE-2020-11013](https://insights.sbomify.com/CVE-2020-11013/): lookup Function Information Discolosure in Helm (high 8.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-25620 and fix it if it is affected.

What it is: CVE-2024-25620 is a medium-severity path traversal vulnerability in helm, published on 14 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-25620 exists.

Affected packages and fixed versions:
- helm.sh/helm/v3 (Go): affected all versions; fixed in 3.14.1
- helm.sh/helm/v3 (Go): affected all versions; fixed in 3.14.1
- helm.sh/helm/v3 (Go): affected all versions; fixed in 3.14.1
- helm (Bitnami): affected all versions; fixed in 3.14.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-25620/ (Markdown: https://insights.sbomify.com/CVE-2024-25620/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-25620
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-25620
- OSV: https://osv.dev/vulnerability/CVE-2024-25620

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-25620/
Summaries are generated and may contain mistakes; the official description above is the record.
