CVE-2024-25621 containerd affected by a local privilege escalation via wide permissions on CRI directory

High 7.3 Published Updated

Local attackers can escalate privileges due to overly broad default permissions on containerd runtime directories.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-25621?

CVE-2024-25621 is a high-severity vulnerability in containerd, published on 6 Nov 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

Official description

containerd is an open-source container runtime. Versions 0.1.0 through 1.7.28, 2.0.0-beta.0 through 2.0.6, 2.1.0-beta.0 through 2.1.4 and 2.2.0-beta.0 through 2.2.0-rc.1 have an overly broad default permission vulnerability. Directory paths `/var/lib/containerd`, `/run/containerd/io.containerd.grpc.v1.cri` and `/run/containerd/io.containerd.sandbox.controller.v1.shim` were all created with incorrect permissions. This issue is fixed in versions 1.7.29, 2.0.7, 2.1.5 and 2.2.0. Workarounds include updating system administrator permissions so the host can manually chmod the directories to not have group or world accessible permissions, or to run containerd in rootless mode.

Weakness: CWE-279

Which versions are affected by CVE-2024-25621?

10 open source packages ship an affected version, including github.com/containerd/containerd/v2 and github.com/containerd/containerd. It affects 1 product.

PackageAffectedFixed in
github.com/containerd/containerd/v2 GoAll versions2.0.7, 2.1.5, 2.2.0
github.com/containerd/containerd/v2 GoAll versions2.0.7
github.com/containerd/containerd/v2 GoAll versions2.0.7
github.com/containerd/containerd/v2 GoFrom 2.1.0-beta.02.1.5
github.com/containerd/containerd/v2 GoFrom 2.1.0-beta.02.1.5
github.com/containerd/containerd/v2 GoFrom 2.2.0-beta.02.2.0
4 more packages
github.com/containerd/containerd/v2 GoFrom 2.2.0-beta.02.2.0
github.com/containerd/containerd GoAll versions1.7.29
github.com/containerd/containerd GoAll versions1.7.29
github.com/containerd/containerd GoAll versions1.7.29

Products include Linuxfoundation Containerd.

How do I fix CVE-2024-25621?

Upgrade github.com/containerd/containerd/v2 to a fixed version for your release line: 2.0.7, 2.1.5 or 2.2.0.

Is CVE-2024-25621 being exploited?

There is no known exploitation of CVE-2024-25621 in the wild and no public exploit code.

Sources

Also known as AZL-69734, AZL-69808, AZL-69812, AZL-69815, BELL-CVE-2024-25621, CLEANSTART-2026-EF16612 and 158 more.

Is CVE-2024-25621 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free