# CVE-2024-25625: Pimcore Host Header Injection in user invitation link

> Attackers can manipulate host headers to generate malicious invitation links, enabling phishing attacks against Pimcore users.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Feb 2024
- **Updated:** 14 Aug 2024
- **Also known as:** GHSA-3qpq-6w89-f7mx

## What is CVE-2024-25625?

CVE-2024-25625 is a high-severity vulnerability in pimcore admin-ui-classic-bundle, published on 19 Feb 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Pimcore's Admin Classic Bundle provides a Backend UI for Pimcore. A potential security vulnerability has been discovered in `pimcore/admin-ui-classic-bundle` prior to version 1.3.4. The vulnerability involves a Host Header Injection in the `invitationLinkAction` function of the UserController, specifically in the way `$loginUrl` trusts user input.  The host header from incoming HTTP requests is used unsafely when generating URLs. An attacker can manipulate the HTTP host header in requests to the /admin/user/invitationlink endpoint, resulting in the generation of URLs with the attacker's domain. In fact, if a host header is injected in the POST request, the $loginURL parameter is constructed with this unvalidated host header. It is then used to send an invitation email to the provided user. This vulnerability can be used to perform phishing attacks by making the URLs in the invitation links emails point to an attacker-controlled domain. Version 1.3.4 contains a patch for the vulnerability. The maintainers recommend validating the host header and ensuring it matches the application's domain. It would also be beneficial to use a default trusted host or hostname if the incoming host header is not recognized or is absent.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2024-25625?

2 open source packages ship an affected version, including pimcore/admin-ui-classic-bundle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pimcore/admin-ui-classic-bundle` | Packagist | All versions | 1.3.4 |
| `pimcore/admin-ui-classic-bundle` | Packagist | All versions | 1.3.4 |

Products: Pimcore Admin Classic Bundle.

## How do I fix CVE-2024-25625?

Upgrade pimcore/admin-ui-classic-bundle to 1.3.4 or later.

## Is CVE-2024-25625 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-25625 exists.

## Other vulnerabilities in pimcore admin-ui-classic-bundle

- [CVE-2024-23646](https://insights.sbomify.com/CVE-2024-23646/): Pimcore Admin Classic Bundle SQL Injection in Admin download files as zip (high 8.8)
- [CVE-2024-23648](https://insights.sbomify.com/CVE-2024-23648/): Pimcore Admin Classic Bundle host header injection in the password reset (high 8.8)
- [CVE-2023-49075](https://insights.sbomify.com/CVE-2023-49075/): Pimcore Admin UI has Two Factor Authentication disabled for non admin security firewalls (high 8.5)
- [CVE-2025-24980](https://insights.sbomify.com/CVE-2025-24980/): Pimcore Admin Classic Bundle allows user enumeration (medium 6.9)
- [CVE-2024-24822](https://insights.sbomify.com/CVE-2024-24822/): Pimcore Admin Classic Bundle permissions are not getting checked when working with tags (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-25625 and fix it if it is affected.

What it is: CVE-2024-25625 is a high-severity vulnerability in pimcore admin-ui-classic-bundle, published on 19 Feb 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-25625 exists.

Affected packages and fixed versions:
- pimcore/admin-ui-classic-bundle (Packagist): affected all versions; fixed in 1.3.4
- pimcore/admin-ui-classic-bundle (Packagist): affected all versions; fixed in 1.3.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-25625/ (Markdown: https://insights.sbomify.com/CVE-2024-25625/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-25625
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-25625
- OSV: https://osv.dev/vulnerability/CVE-2024-25625

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-25625/
Summaries are generated and may contain mistakes; the official description above is the record.
