# CVE-2024-25630: Cilium has unencrypted ingress/health traffic when using Wireguard transparent encryption

> Attackers can read unencrypted ingress and health traffic in Cilium clusters using WireGuard encryption, exposing sensitive data.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Feb 2024
- **Updated:** 1 Aug 2024
- **Also known as:** BIT-cilium-2024-25630, BIT-cilium-operator-2024-25630, BIT-cilium-proxy-2024-25630, BIT-hubble-2024-25630, BIT-hubble-relay-2024-25630, BIT-hubble-ui-2024-25630, BIT-hubble-ui-backend-2024-25630, GHSA-7496-fgv9-xw82, GO-2024-2568

## What is CVE-2024-25630?

CVE-2024-25630 is a medium-severity vulnerability in cilium, published on 20 Feb 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Cilium is a networking, observability, and security solution with an eBPF-based dataplane. For Cilium users who are using CRDs to store Cilium state (the default configuration) and Wireguard transparent encryption, traffic to/from the Ingress and health endpoints is not encrypted. This issue affects Cilium v1.14 before v1.14.7 and has been patched in Cilium v1.14.7. There is no workaround to this issue.

Weakness: CWE-319 (Cleartext Transmission of Sensitive Information), CWE-311 (Missing Encryption of Sensitive Data)

## Which versions are affected by CVE-2024-25630?

10 open source packages ship an affected version, including github.com/cilium/cilium, cilium and cilium-operator. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/cilium/cilium` | Go | From 1.14.0 | 1.14.7 |
| `github.com/cilium/cilium` | Go | From 1.14.0 | 1.14.7 |
| `github.com/cilium/cilium` | Go | From 1.14.0 | 1.14.7 |
| `cilium` | Bitnami | From 1.14.0 | 1.14.7 |
| `cilium-operator` | Bitnami | From 1.14.0 | 1.14.7 |
| `cilium-proxy` | Bitnami | From 1.14.0 | 1.14.7 |
| `hubble` | Bitnami | From 1.14.0 | 1.14.7 |
| `hubble-relay` | Bitnami | From 1.14.0 | 1.14.7 |
| `hubble-ui` | Bitnami | From 1.14.0 | 1.14.7 |
| `hubble-ui-backend` | Bitnami | From 1.14.0 | 1.14.7 |

Products: Cilium Cilium.

## How do I fix CVE-2024-25630?

Upgrade github.com/cilium/cilium to 1.14.7 or later.

## Is CVE-2024-25630 being exploited?

There is no known exploitation of CVE-2024-25630 in the wild and no public exploit code.

## Other vulnerabilities in cilium

- [CVE-2026-49445](https://insights.sbomify.com/CVE-2026-49445/): Cilium: Sensitive information disclosure and cluster disruption via local Envoy admin socket access (critical 9.2)
- [CVE-2022-29178](https://insights.sbomify.com/CVE-2022-29178/): Incorrect Default Permissions in Cilium (high 8.8)
- [CVE-2024-28860](https://insights.sbomify.com/CVE-2024-28860/): Insecure IPsec transport encryption in Cilium (high 8.0)
- [CVE-2026-41520](https://insights.sbomify.com/CVE-2026-41520/): Cillium exposes sensitive information included in the cilium-bugtool debug archive (high 7.9)
- [CVE-2024-37307](https://insights.sbomify.com/CVE-2024-37307/): Cilium leaks sensitive information in cilium-bugtool (high 7.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-25630 and fix it if it is affected.

What it is: CVE-2024-25630 is a medium-severity vulnerability in cilium, published on 20 Feb 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-25630 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/cilium/cilium (Go): affected from 1.14.0; fixed in 1.14.7
- github.com/cilium/cilium (Go): affected from 1.14.0; fixed in 1.14.7
- github.com/cilium/cilium (Go): affected from 1.14.0; fixed in 1.14.7
- cilium (Bitnami): affected from 1.14.0; fixed in 1.14.7
- cilium-operator (Bitnami): affected from 1.14.0; fixed in 1.14.7
- cilium-proxy (Bitnami): affected from 1.14.0; fixed in 1.14.7
- hubble (Bitnami): affected from 1.14.0; fixed in 1.14.7
- hubble-relay (Bitnami): affected from 1.14.0; fixed in 1.14.7
- hubble-ui (Bitnami): affected from 1.14.0; fixed in 1.14.7
- hubble-ui-backend (Bitnami): affected from 1.14.0; fixed in 1.14.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-25630/ (Markdown: https://insights.sbomify.com/CVE-2024-25630/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-25630
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-25630
- OSV: https://osv.dev/vulnerability/CVE-2024-25630

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-25630/
Summaries are generated and may contain mistakes; the official description above is the record.
