# CVE-2024-25637: Reflected XSS via X-October-Request-Handler Header

> Reflected XSS in October CMS via unsanitized header, though exploitation is limited to proxy tools and not normal browser interactions.

- **Severity:** Low 3.1 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Jun 2024
- **Updated:** 1 Aug 2024
- **Also known as:** GHSA-rjw8-v7rr-r563

## What is CVE-2024-25637?

CVE-2024-25637 is a low-severity cross-site scripting vulnerability in Octobercms October, published on 26 Jun 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

October is a self-hosted CMS platform based on the Laravel PHP Framework. The X-October-Request-Handler Header does not sanitize the AJAX handler name and allows unescaped HTML to be reflected back. There is no impact since this vulnerability cannot be exploited through normal browser interactions. This unescaped value is only detectable when using a proxy interception tool. This issue has been patched in version 3.5.15.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-25637?

2 open source packages ship an affected version, including october/system. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `october/system` | Packagist | From 3.2 | 3.5.15 |
| `october/system` | Packagist | From 3.2 | 3.5.15 |

Products: Octobercms October.

## How do I fix CVE-2024-25637?

Upgrade october/system to 3.5.15 or later.

## Is CVE-2024-25637 being exploited?

There is no known exploitation of CVE-2024-25637 in the wild and no public exploit code.

## Other vulnerabilities in Octobercms October

- [CVE-2021-32648](https://insights.sbomify.com/CVE-2021-32648/): October CMS Improper Authentication (high 8.2, exploited in the wild)
- [CVE-2021-3311](https://insights.sbomify.com/CVE-2021-3311/): October CMS Session ID not invalidated after logout (critical 9.8)
- [CVE-2017-1000194](https://insights.sbomify.com/CVE-2017-1000194/): October CMS File Upload Vulnerability (critical 9.8)
- [CVE-2017-1000196](https://insights.sbomify.com/CVE-2017-1000196/): Code injection in n/a (critical 9.8)
- [CVE-2017-1000197](https://insights.sbomify.com/CVE-2017-1000197/): Path traversal in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-25637 and fix it if it is affected.

What it is: CVE-2024-25637 is a low-severity cross-site scripting vulnerability in Octobercms October, published on 26 Jun 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-25637 in the wild and no public exploit code.

Affected packages and fixed versions:
- october/system (Packagist): affected from 3.2; fixed in 3.5.15
- october/system (Packagist): affected from 3.2; fixed in 3.5.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-25637/ (Markdown: https://insights.sbomify.com/CVE-2024-25637/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-25637
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-25637
- OSV: https://osv.dev/vulnerability/CVE-2024-25637

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-25637/
Summaries are generated and may contain mistakes; the official description above is the record.
