{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-25640 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2024-25640 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-25640 is a medium-severity cross-site scripting vulnerability in dfir-iris iris-web, published on 19 Feb 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-25640 and fix it if it is affected.\n\nWhat it is: CVE-2024-25640 is a medium-severity cross-site scripting vulnerability in dfir-iris iris-web, published on 19 Feb 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-25640 in the wild and no public exploit code.\n\nAffected product: dfir-iris iris-web. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-25640/ (Markdown: https://insights.sbomify.com/CVE-2024-25640/index.md)","id":"CVE-2024-25640","markdown":"https://insights.sbomify.com/CVE-2024-25640/index.md","name":"CVE-2024-25640","record":{"aliases":["GHSA-2xq6-qc74-w5vp"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"IRIS incident response platform","requires_auth":"low_privilege","summary":"Authenticated attackers can inject malicious scripts into the IRIS web platform, potentially leading to data theft or account takeover.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"iris","vendor":"dfir-iris"}],"cvss":{"score":4.6,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"},{"id":"CWE-87","name":"Improper Neutralization of Alternate XSS Syntax"}],"description":"Iris is a web collaborative platform that helps incident responders share technical details during investigations. A stored Cross-Site Scripting (XSS) vulnerability has been identified in iris-web, affecting multiple locations in versions prior to v2.4.0. The vulnerability may allow an attacker to inject malicious scripts into the application, which could then be executed when a user visits the affected locations. This could lead to unauthorized access, data theft, or other related malicious activities. An attacker need to be authenticated on the application to exploit this vulnerability. The issue is fixed in version v2.4.0 of iris-web. No workarounds are available.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Improper Neutralization of Alternate XSS Syntax in iris-web","id":"CVE-2024-25640","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2024"},"n_packages":0,"n_references":1,"next":{"headline":"Cacti RCE vulnerability when importing packages","id":"CVE-2024-25641"},"packages":[],"prev":{"headline":"Prompt Injection triggered XSS vulnerability in Khoj Obsidian, Desktop and Web clients","id":"CVE-2024-25639"},"products":["iris-web"],"published":"2024-02-19","related":[{"cvss_score":9.6,"headline":"Iris Allows Arbitrary File Deletion via Mass Assignment in Datastore File Management","id":"CVE-2026-22783","kev_date_added":null,"published":"2026-01-12"},{"cvss_score":6.8,"headline":"iris-web vulnerable to Server Side Template Injection in reports","id":"CVE-2024-25624","kev_date_added":null,"published":"2024-04-25"},{"cvss_score":6.3,"headline":"Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) in iris-web","id":"CVE-2023-30615","kev_date_added":null,"published":"2023-05-25"},{"cvss_score":4.6,"headline":"Improper Neutralization of Alternate XSS Syntax in iris-web","id":"CVE-2023-50712","kev_date_added":null,"published":"2023-12-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-01","vendors":["dfir-iris"]},"summary":"Authenticated attackers can inject malicious scripts into the IRIS web platform, potentially leading to data theft or account takeover.","url":"https://insights.sbomify.com/CVE-2024-25640/"}