{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.commons:commons-compress. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-25710 in the wild and no public exploit code.","fix":"Upgrade org.apache.commons:commons-compress to 1.26.0 or later.","what":"CVE-2024-25710 is a high-severity denial of service vulnerability in Apache Commons Compress, published on 19 Feb 2024. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-25710 and fix it if it is affected.\n\nWhat it is: CVE-2024-25710 is a high-severity denial of service vulnerability in Apache Commons Compress, published on 19 Feb 2024. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-25710 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.commons:commons-compress (Maven): affected from 1.3; fixed in 1.26.0\n- org.apache.commons:commons-compress (Maven): affected from 1.3; fixed in 1.26.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-25710/ (Markdown: https://insights.sbomify.com/CVE-2024-25710/index.md)","id":"CVE-2024-25710","markdown":"https://insights.sbomify.com/CVE-2024-25710/index.md","name":"CVE-2024-25710","record":{"aliases":["AZL-34812","AZL-43564","AZL-44916","CLEANSTART-2026-HE16906","CLEANSTART-2026-SD55933","CLSA-2026-1787323198","CLSA-2026-1787326456","CLSA-2026-1787580035","CLSA-2026-1788331098","CLSA-2026-1789370189","CLSA-2026-1792741828","CLSA-2026-1792742148","DEBIAN-CVE-2024-25710","ECHO-cc95-fa77-90fa","GHSA-4g9r-vxhx-9pgx","MINI-3c5v-586v-75mp","MINI-5p4w-6w2c-66cm","MINI-64cv-pxj9-jvp9","MINI-6fh2-xw6c-rhcv","MINI-hpfq-xf4p-w96v","MINI-p6p4-crr3-qg46","MINI-v7vh-mp9p-6x4p","MINI-xqcw-x7c5-5fxm","ROOT-APP-MAVEN-CVE-2024-25710","UBUNTU-CVE-2024-25710"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Java compression library","requires_auth":"none","summary":"An attacker can cause a denial of service via an infinite loop when processing a corrupted DUMP file using Apache Commons Compress.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"commons_compress","vendor":"apache"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-835","name":"Loop with Unreachable Exit Condition"}],"description":"Loop with Unreachable Exit Condition ('Infinite Loop') vulnerability in Apache Commons Compress.This issue affects Apache Commons Compress: from 1.3 through 1.25.0.\n\nUsers are recommended to upgrade to version 1.26.0 which fixes the issue.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Commons Compress: Denial of service caused by an infinite loop for a corrupted DUMP file","id":"CVE-2024-25710","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":2,"n_references":3,"next":{"headline":"diffoscope Path Traversal vulnerability","id":"CVE-2024-25711"},"packages":[{"ecosystem":"Maven","fixed":["1.26.0"],"introduced":["1.3"],"last_affected":[],"package":"org.apache.commons:commons-compress","purl":null,"source":"GHSA-4g9r-vxhx-9pgx"},{"ecosystem":"Maven","fixed":["1.26.0"],"introduced":["1.3"],"last_affected":[],"package":"org.apache.commons:commons-compress","purl":"pkg:maven/org.apache.commons/commons-compress","source":"GHSA-4g9r-vxhx-9pgx"}],"prev":{"headline":"Self-XSS style in move item dialog","id":"CVE-2024-25709"},"products":["Apache Commons Compress"],"published":"2024-02-19","related":[{"cvss_score":7.5,"headline":"Apache Commons Compress 1.6 to 1.20 denial of service vulnerability","id":"CVE-2021-35515","kev_date_added":null,"published":"2021-07-13"},{"cvss_score":7.5,"headline":"Apache Commons Compress 1.6 to 1.20 denial of service vulnerability","id":"CVE-2021-35516","kev_date_added":null,"published":"2021-07-13"},{"cvss_score":7.5,"headline":"Apache Commons Compress 1.1 to 1.20 denial of service vulnerability","id":"CVE-2021-35517","kev_date_added":null,"published":"2021-07-13"},{"cvss_score":7.5,"headline":"Apache Commons Compress 1.0 to 1.20 denial of service vulnerability","id":"CVE-2021-36090","kev_date_added":null,"published":"2021-07-13"},{"cvss_score":7.5,"headline":"Denial of Service in Apache Commons Compress","id":"CVE-2019-12402","kev_date_added":null,"published":"2019-08-29"},{"cvss_score":5.5,"headline":"Apache Commons Compress: OutOfMemoryError unpacking broken Pack200 file","id":"CVE-2024-26308","kev_date_added":null,"published":"2024-02-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-04","vendors":["Apache Software Foundation"]},"summary":"An attacker can cause a denial of service via an infinite loop when processing a corrupted DUMP file using Apache Commons Compress.","url":"https://insights.sbomify.com/CVE-2024-25710/"}