# CVE-2024-25713: yyjson has a Double Free vulnerability

> A double free vulnerability in the yyjson library allows remote attackers to execute arbitrary code via crafted JSON input.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Feb 2024
- **Updated:** 4 Nov 2025
- **Also known as:** GHSA-q4m7-9pcm-fpxh, GHSA-whx6-m9j4-w2m2

## What is CVE-2024-25713?

CVE-2024-25713 is a high-severity memory corruption vulnerability in Fedoraproject Fedora, published on 11 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

yyjson through 0.8.0 has a double free, leading to remote code execution in some cases, because the pool_free function lacks loop checks. (pool_free is part of the pool series allocator, along with pool_malloc and pool_realloc.)

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2024-25713?

2 open source packages ship an affected version, including github.com/ibireme/yyjson. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/ibireme/yyjson` | SwiftURL | All versions | 0.9.0 |
| `github.com/ibireme/yyjson` | SwiftURL | All versions | 0.9.0 |

Products: Fedoraproject Fedora, Ibireme Yyjson.

## How do I fix CVE-2024-25713?

Upgrade github.com/ibireme/yyjson to 0.9.0 or later.

## Is CVE-2024-25713 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-25713 exists.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-25713 and fix it if it is affected.

What it is: CVE-2024-25713 is a high-severity memory corruption vulnerability in Fedoraproject Fedora, published on 11 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-25713 exists.

Affected packages and fixed versions:
- github.com/ibireme/yyjson (SwiftURL): affected all versions; fixed in 0.9.0
- github.com/ibireme/yyjson (SwiftURL): affected all versions; fixed in 0.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-25713/ (Markdown: https://insights.sbomify.com/CVE-2024-25713/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-25713
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-25713
- OSV: https://osv.dev/vulnerability/CVE-2024-25713

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-25713/
Summaries are generated and may contain mistakes; the official description above is the record.
