CVE-2024-25723 ZenML Server Remote Privilege Escalation Vulnerability
Remote attackers can escalate privileges by activating user accounts via an insecure API endpoint in ZenML Server.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-25723?
CVE-2024-25723 is a high-severity authentication bypass vulnerability in n/a, published on 27 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
ZenML Server in the ZenML machine learning package before 0.46.7 for Python allows remote privilege escalation because the /api/v1/users/{user_name_or_id}/activate REST API endpoint allows access on the basis of a valid username along with a new password in the request body. These are also patched versions: 0.44.4, 0.43.1, and 0.42.2.
Weakness: CWE-284
Which versions are affected by CVE-2024-25723?
9 open source packages ship an affected version, including zenml. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
zenml PyPI | All versions | 0.42.2, 0.43.1, 0.44.4, 0.46.7 |
zenml PyPI | All versions | 0.42.2 |
zenml PyPI | All versions | 0.42.2 |
zenml PyPI | From 0.43.0 | 0.43.1 |
zenml PyPI | From 0.43.0 | 0.43.1 |
zenml PyPI | From 0.44.0 | 0.44.4 |
3 more packages
zenml PyPI | From 0.44.0 | 0.44.4 |
zenml PyPI | From 0.45.0 | 0.46.7 |
zenml PyPI | From 0.45.0 | 0.46.7 |
Products include Zenml Zenml.
How do I fix CVE-2024-25723?
Upgrade zenml to a fixed version for your release line: 0.42.2, 0.43.1, 0.44.4 or 0.46.7.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2024-25723 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-25723 exists.
Public exploit code: 1 Nuclei template and 1 proofs of concept on GitHub.
Other vulnerabilities in n/a
Sources
Also known as GHSA-vf7j-cmrj-pmmm, PYSEC-2026-2072.